Release – 1.7.3

Published: 28.03.2019

In this article you can find out which

  • New features are available
  • Which improvements have been implemented for users
  • Bug fixes included with the release of 1.7.3

This article can also be downloaded as a PDF. The release notes from previous versions can be downloaded from the archive.

1. Overview

With version 1.7.3, we have added some new features for Variable Data, Fixups, Administration of user-defined metadata and connecting the Workflow to leading ERP/MIS systems. We've also added additional improvements to the Impose Editor, Role Permissions and Profiling. The Master Data in the Workflow now includes common Inks used in United States as well as new options for Printer Types.

Below is an overview of all updates and changes. A detailed description is then provided under the New functions and Features, General Improvements and Bug Fixes & Minor Details sections.

1.1. Adobe Illustrator Plug-in

The following new features and improvements are available for Plug-in version 1.7.3.54:

Support for standard Barcode sizes: For EAN & ISBN Barcodes, standard Barcode sizes - also known as SC sizes - have been implemented. These can be selected and used in the Plug-in.

Extended functions for Bearer-Bars: Bearer Bars can be defined by using Extended Barcode functions. With this version, Bearer Bars can be set on all four sides - as a frame for example.

High-resolution display of Barcodes: Barcodes are now generated both in the display and in the output with vectors. Fuzzy previews are a thing of the past.

Updated Plug-in Translations: We've included full language versions including: English, German and French.

1.2. New Functions in the Workflow

The following new features are available in version 1.7.3 of the Workflow:

User-defined Fields: As of version 1.7.3, User-defined Fields are available in the Workflow. In addition to the fields previously available in the Workflow, fully customizable, User-defined Fields are now available for Articles, Orders and Production Jobs. Further details pertaining to the creation, display, editing and applying these fields in Reports can be found in the following areas:

DXF-Export for Esko Kongsberg Cutters: For Esko Kongsberg Cutter devices, a DXF-Export was implemented in addition to the existing HPGL-Export, to optimise exporting these files.

Rest API: The functionality of the Rest-API has been extended to implement User-defined Fields as well as Article Collections. Currently, the following activities can be mapped to the Rest API:

  • Create new Customers with Contact Persons and Addresses
  • Create Articles with available metadata
  • Create a Collection (New)
  • Create Orders with an unlimited number of Order Items and several Print Items per Order Item plus all metadata for the Order
  • Create Production Jobs plus all metadata for the Production Job
  • Transferring Data to existing User-defined Fields (New)
  • We've also improved the Login process (New)

Manual Impose Mode: New and existing functions in Manual Mode have been implemented and/or improved:

Nesting Mode: Nesting with Print Items of different dimensions

  • Adding vertical and horizontal spacing is now possible

1.3. General Improvements

We have improved the following functions with version 1.7.3 of the Workflow:

Profiling: The Profiling step/dialog has been revised. New functions from version 1.7.2 were partially optimized for the current version:

Printer Type Parameters: Different Printing Systems require specific settings and dialogs. We've revised certain dialogs and settings as necessary. The following options were added to Printer Types in this version and can only be accessed when the Printer Type supports them:

Role Permissions: Numerous changes have been made to Role Permissions. Adjustments were made, as well as new options to fine tune Role Permissions.

Inks: New Ink Families & Inks have been added common to the American market.

Fixups (Correction Profiles): Improvements have been made to make the Fixups more user friendly in the UI. The following new Fixups are available:

PDFChip 2.0: With the update of PDFChip 2.0 the user will experience an enormous speed improvement when creating multipage PDF's with Variable Data as well as increased positioning accuracy, which was partially visible during longer repetitions.

1.4. Fixed Bugs & Minor Details

Workflow: A list of fixed bugs and/or minor improvements in the Workflow

Impose Editor: A list of fixed bugs and/or minor improvements in the Impose Editor

Adobe Illustrator Plug-in: A list of fixed bugs and/or minor improvements in the Illustrator Plug-in

2. New Functions

2.1. Adobe Illustrator Plug-in

If you are using version 1.7.3 of the Workflow, Plug-in version 1.7.3.54 must be installed. If you are using an older version, you will be notified when logging in.

The following versions of Adobe Illustrator are supported:


Adobe Illustrator 2017 Adobe Illustrator 2018
Adobe Illustrator 2019
MacOSX Mac OS Version 10.12 (Sierra) or Mac OS Version 10.11 (El Capitan)
Mac OS Version 10.14 (Mojave), Mac OS Version 10.13 (High Sierra), Mac OS Version 10.12 (Sierra) or Mac OS Version 10.11 (El Capitan)
Mac OS Version 10.14 (Mojave), Mac OS Version 10.13 (High Sierra), Mac OS Version 10.12 (Sierra) or Mac OS Version 10.11 (El Capitan)
Windows Windows 7 mit Service Pack 1, Windows 8.1 oder Windows 10
Microsoft Windows 7 with Service Pack 1, Windows 8.1 or Windows 10
Microsoft Windows 7 with Service Pack 1, Windows 8.1 or Windows 10
Supports Plug-in Version 1.7.0.26
Plug-in Version 1.7.0.26 and Plug-in Version 1.7.3.54
Plug-in Version 1.7.3.54

Current version not available for older Illustrator versions

Please note that Plug-in version 1.7.3.54 can only be installed for Adobe Illustrator 2018 and Adobe Illustrator 2019. Adobe Illustrator 2017 and 2015.3 can still be used with Plug-in version 1.7.026.

2.1.1. Support for Standard Barcode sizes

EAN and ISBN Barcodes can now be created in the required sizes on demand. In previous versions, it was possible to create a Barcode of any size and then completely change it afterwards. According to ISO/IEC 15420, the sizes of EAN and ISBN Barcodes are officially standardized in the form of SC sizes. In the packaging and label industry, these specifications are often requested by customers.

Table 1: SC Barcode sizes according to the ISO/IEC 15420 standard.


Scale factor compared to SC 2 (100%) Width in mm Height in mm
Tolerance in mm
SC 0  82% 30,5 21,48
0,042
SC 1
90%
33,56
23,34
0,068
SC 2
100%
37,29
25,93
0,101
SC 3
110%
41,02
28,52
0,115
SC 4
120%
44,75
31,12
0,131
SC 5
135%
50,34
35,01
0,156
SC 6
150%
55,94
38,90
0,178
SC 7
165%
61,53
42,78
0,2
SC 8
185%
68,99
47,97
0,233
SC 9 1
200%
74,58
51,86
0,255

SC 2 represents the standard size. These dimensions measure: 25.93 mm [1] in height by 37.29 mm [2] in width. According to the standard, these values may be reduced proportionally to a minimum of 80% or increased to 200%. The so-called SC values reflect the standard value in different sizes.

Figure 1: A size specification of the SC 2 standard using an EAN 13 Barcode as an example.

After selecting an EAN or ISBN Barcode in the Adobe Illustrator Plug-in, the Use SC Size option is available. By activating this checkbox, the SC size can be selected in the a drop-down menu. If this option is not activated, a Barcode can be created in any size.

Creating a Barcode with a standardized SC size works as follows:

  1. In Adobe Illustrator checked out a Print Item from the Workflow.
  2. Use the Rectangle tool to draw a rectangle to generate a Barcode.
  3. Select the rectangle you created using the Selection tool.
  4. Activate the Barcode Tool [3] in the Variable Data or Static Barcode Panel.
  5. Under Type [4], select an EAN or ISBN Barcode.
  6. Enter all necessary parameters to create a valid Barcode.
  7. Enable the Use SC Size option [5]. After activating this option, the selected rectangle is reduced or enlarged according to the selected SC size. Once this option is active, manual changes in size can no longer be made. When using SC sizes, the Apply SC Height [6] option is also activated by default so that the height of the Barcode cannot be changed. This option can also be disabled if the height of the Barcode needs to be adjusted.

Figure 2: The VDP panel of the Adobe Illustrator Plug-in where SC sizes can be selected.

Plug-in - SC Size - 1.7.3.43

The Barcode text size - if Show Text [7] is activated - will also adapt to the SC size. The predefined text size can also be adjusted manually if necessary. The following text sizes result from the selected SC size:

  • Barcode size SC 0 > 8pt Font size
  • Barcode size SC 1 > 8pt Font size
  • Barcode size SC 2 > 9pt Font size
  • Barcode size SC 3 > 9pt Font size
  • Barcode size SC 4 > 11pt Font size
  • Barcode size SC 5 > 11pt Font size
  • Barcode size SC 6 > 14pt Font size
  • Barcode size SC 7 > 14pt Font size
  • Barcode size SC 8 > 16pt Font size
  • Barcode size SC 9 > 16pt Font size

2.1.2. Additional Parameters for Bearer Bars

The Bearers section has been available for a while now, but under the Additional Parameters section of the Barcode panel, the user can enter and set limitations for the Barcode. Until now, Bearer Bars could only be set above, below and on both sides. With this version Bearer Bars can also be created, displayed and rendered on all four sides - as a frame.

In most cases only ITF-14 Barcode Bearer Bars are needed. If Bearer Bars have to be generated on all four sides, it may be necessary to create space on the left and right side of the Barcode. You can create this space by specifying the desired size under the Quiet Zone settings. If no Quite Zone is set, the frame around the Barcode cannot be generated.

Below we describe how to create a frame around an ITF-14 Barcode in the Bearers area, and also what to be aware of:

  1. Open Adobe Illustrator and check out a Print Item from the Workflow.
  2. Draw a rectangle with the Rectangle tool.
  3. Select the rectangle you've created.
  4. Activate the Barcode Tool [8] under the Variable Data or Static Barcode Panel.
  5. Under Type [9], select an ITF-14 Barcode.
  6. Enter all necessary parameters to create a valid Barcode.
  7. Under the Additional Parameters area [10], open the Bearers fly-out options [13].
  8. Select Frame under the Position drop-down menu [14].
  9. Enter a Width [15] of 1mm. If no Quiet Zone has been defined, the Barcode will no longer be displayed. An error message: Barcode Error: If 'Rectangle' used for Bearers, please define Quiet Zone left and right is displayed under the Preview panel.
  10. Under the Additional Parameters area [10], open Quiet Zone [11].
  11. Define a 12 X Quiet Zone left and right [12]. As soon as the Quiet Zone is large enough, the Barcode can be generated. For a Bearer width of one millimeter, 12 X Quiet Zones left and right are required. The larger the Bearer width, the smaller the Barcode is, more Quiet Zone left and right is required.

Figure 3: A section of the VDP panel in the Adobe Illustrator plug-in, where a frame is set under Bearers to create a frame around the Barcode.

Bearer Bars - ITF 14 - 1.7.3

2.1.3. High-resolution display of Barcodes

Up to version 1.7.3, the preview of the Barcode generated in the VDP panel was placed as an image in Illustrator. As a result, when printing a Print Item from Adobe Illustrator, the line thickness of the Barcode was not printed accurately enough (slightly blurred by antialiasing). The Barcode readability failed in most cases.

This situation did not appear in the same way when generating Barcodes in the Static Barcode panel, since a vector graphic was always generated here when generating a Barcode. In the course of this release, the procedure for generating Barcodes was standardized. In both cases, Barcodes are now always generated as a vector. The print quality and legibility of Barcodes created in Illustrator are now consistent.

2.1.4. Updated Translations

We have internally changed the way translations are handled in the Workflow and the Plug-in. Version 1.7.3 contains a general revision of terms, labels and error messages. The following changes have been made:

  • The Plug-in can now be opened via Window > PPD with the panels inside.
  • The names of the individual panels have been adapted and translated into their respective languages.
  • The terms and designations for individual fields have been revised in the English version.
  • A fully translated German version of the Plug-in is now available.
  • A completely translated French version of the Plug-in is now available.
  • A fully translated Japanese version of the Plug-in is now available.

The Spanish and Italian language versions will be available with the next release.

2.2. User-defined Fields

The Workflow almost exclusively contains input fields that are relevant for production or for searching lists of data. These fields are automatically generated by the system and can be used or not, depending on the user's needs.

However, there are users who require additional fields to fully describe an Article, Order, or Production Job in the Workflow. For example, this could be additional information that is only relevant when communicating with a specific customer. Such additional fields - for example: logistics information, packaging, Article descriptions, customer order numbers, etc., could not previously be mapped in the Workflow.

Version 1.7.3 offers the possibility to create and display User-defined Fields. Users can fully customize input fields for Articles, Orders and Production Jobs - as text or number entries, dropdown menus or checkboxes. User administration can also determine whether the user has access to these input fields, or if they can only view them and/or edit them according to permissions granted.

User-defined fields are not available in all licenses

Note that this option is only available for Create and Create+ users. Licensees who have only purchased Produce will not be able to use this functionality.

2.2.1. Creating a User-defined Field

User-defined Fields can only be created by a system administrator. The system administrator must decide which fields or which field types should be added to which areas. Currently, User-defined Fields can only be created via the Master Data. The creation of User-defined Fields via the user interface will be added in a future release.

Figure 4: Master Data with the Custom Field database selected.

To create a User-defined Field, proceed as follows:

  1. Login to the Workflow as an Administrator.
  2. Select the menu item Administration > Settings > General
  3. Activate the Extended View checkbox to gain access to the Master Data.
  4. Click on Save. If you click away from the General Settings tab without saving you will be asked to confirm if you want to save your settings.
  5. Switch to the Administration > Master Data [17] menu item.
  6. Select the Custom Field table from the list of tables [16].

    This table will be empty by default as long as no User-defined Fields have been created in the Workflow.
  7. Select the Add Record button [18] to create a new Custom Field.
  8. Fill in all necessary input fields in the Custom Field dialog [19] and click on Save.
  9. After all User-defined Fields have been created, the PMS service must be restarted.

Figure 5: The Create New Custom Field dialog in the Master Data.

Create New Custom Field - 1.7.3

Individual Parameters of a User-defined Field

  • key [20]: The key of a User-defined Field must be unique, i.e. it may only occur once in the system. Furthermore, it must be written in capital letters and must not contain any spaces or special characters, i.e. only ASCII characters including underscore "_". This key is not displayed in the system - it is only used to identify the field internally.
  • entity_table_name [21]: Here you should define to which table the User-defined Field should to be added or where it should be displayed in the Workflow. There are currently four different options:
    • article – Adds the User-defined Field to the Article table and is displayed in an Article
    • motif – Adds the User-defined Field to the Motif table (Motifs in Orders & Production Jobs)
    • print_order – Adds the User-defined Field to the Order table
    • production_job – Adds the User-defined Field to the Production Job table
  • label [22]: This input field is used for labeling within the user interface. Use a name that is content appropriate.
  • comment [23]: Add an optional comment which can be saved for each User-defined Field. Please note, this comment is only displayed in the Master Data.
  • field_order [24]: This input determines the order in which all User-defined Fields are displayed in the Workflow. Note that the sequence number is assigned per "entity_table_name".
  • value_type_key [25]: This list offers three different field types which can be selected:
    • (BOOLEAN) – Is displayed as a checkbox in the user interface.
    • (STRING) – Is displayed in the user interface as a text input field. Any number of characters can be entered.
    • Number incl. fractions (NUMERIC) – Is displayed in the user interface as a number input.
  • default_value [26]: For each field a value can be defined, which is already preselected by default.
  • mandatory field [27]: Displayed in the user interface as mandatory field* - with Asterix.
  • status [28]: Is used by the system, must not be filled.
  • error_message [29]: Used by the system, must not be filled.
  • options [30]: Here you can define whether the field should be displayed as a selection list. Each value to be selected must be defined in this area. The structure of a selection list should be structured as follows:
[


  {

    "value": "Selection A"

  },


  {

    "value": "Selection B"

  }


]
  • UI Config for custom field [31]: Here you can define how the User-defined Field should be formatted. At the moment, you can only specify whether it is to be formatted as a single-line text input field or as a multiline text input field. If no entry is made, a single-line text input field is displayed. If you want a multiline text input field in the user interface, the entry must look like this:
{
  "multiline": true
}
  • created [32]: Used by the system, must not be filled.
  • created_by [33]: Used by the system, must not be filled.
  • last_modified [34]: Used by the system, must not be filled.
  • last_modified_by [35]: Used by the system, must not be filled.

PMS must be restarted

After all User-defined Fields have been created in the Master Data, the PMS Service must be restarted on the Workflow workstation. User-defined Fields can then be used in the system.

2.2.2. Viewing a User-defined Field

After User-defined Fields are defined in the Master Data and the Workflow Workstation PMS Service is restarted, the User-defined Fields will then be displayed in their respective areas and can be used. Depending on the tables to which they have been added, they are displayed under different menu items. There they can be viewed and edited.

Articles

User-defined Fields for an Article can be viewed and edited in two different places. However, the normal location of User-defined Fields is in the Article View under Document, Production Information and User-defined Fields [36]. After you have located this view, please follow the next steps described below.

Figure 6: The Document, Production Information and User-defined Fields view in the Article View.

To access the User-defined fFields for an Article, proceed as follows:

Variation A

  1. Select Article > Article list
  2. Open an Article
  3. Navigate to the last page [37] of Document, Production Information and User-defined Fields [36].

Variant B

  1. Select Article > Article List  from the menu bar.
  2. Select an Article from the list.
  3. Choose Edit > Edit Article from the action bar.
  4. In the Edit Article dialog [38] switch to the User-defined Fields tab [39].

In these two areas, all User-defined Fields that have been added to the Article table are listed. By default, all defined default_values are displayed. Sorting is also taken into account here.

Figure 7: The User-defined Fields tab in the Edit Article dialog.

Edit Article - Custom Field - 1.7.3

Print Item

User-defined Fields for Print Items contained in an Order or Production Job can also be displayed in Print Item view under Document, Production Information and User-defined Fields. To access the User-defined Fields for Print Items, proceed as follows:

  1. Open an Order or Production Job.
  2. Select a Print Item in the Order or Production Job.
  3. Navigate to Document, Production Information, and User-defined Fields.

This area lists all User-defined Fields that have been added to the motif table. By default, all defined default_values are displayed. Sorting is also taken into account here.

Order

User-defined Fields for an Order are displayed under Order Information [40]. To locate User-defined Fields for an Order, follow the steps described below:

Figure 8: User-defined Fields for an Order can be found under the Order Information tab.

To access the User-defined Fields for Orders, proceed as follows:

  1. Navigate to the Order List.
  2. Select an Order from the list and open it.
  3. Switch from Print Item tab - to the Order Information tab [40].
  4. Click on the User-defined Fields tab [41].

This tab lists all User-defined Fields that have been added to the print_order table. By default, all defined default_values are displayed. Sorting is also taken into account here.

Production Job

The User-defined Fields of the Production Job are displayed directly in the Production Job. Follow the steps described below to locate them:

Figure 9: The User-defined Fields tab of a Production Job.

 

To access the User-defined Fields for a Production Job, proceed as follows:

  1. Select Production Job from the menu bar.
  2. Open a Production Job from the list.
  3. Switch to the User-defined Fields tab [42].

This area lists all User-defined Fields that have been added to the production_job table. By default, all defined default_values are displayed. Sorting is also taken into account here.

»User-defined fields« tab can't be accessed

It should be noted that User-defined Fields cannot be accessed when a Produce License has been purchased.

2.2.3. Editing User-defined Fields

In each area - Article, Print Item, Orders and Production JobsUser-defined Fields can be adapted or edited in the aforementioned areas. Follow the steps described below:

Articles

To edit User-defined Fields for Articles, proceed as follows:

  1. Select Article > Article List from the menu
  2. Open an Article
  3. Locate Document, Production Information and User-defined Fields [44]
  4. Activate the Edit Custom Fields button [43]

Figure 10: The Document, Production Information and User-defined Fields area of an Article.

  1. The Edit User-defined Fields dialog [45] opens, which displays all User-defined Fields. Here fields can be edited and saved. Fields marked as mandatory in the Master Data must then be filled in. All other fields can optionally be filled with content.

Figure 11: The Edit User-defined Fields dialog in Article view

Edit User-defined Fields dialog - 1.7.3

Further options when editing User-defined Fields

The User-defined Fields for an Article can also be displayed and edited in the Edit Article dialog (Figure 7). If you want to edit entries in User-defined Fields across multiple Articles, you must select the Articles in the Article List and select the command Edit > Edit Selected Articles in the action bar.

Print Item

The User-defined Fields for a Print Item contained in an Order or Production Job can also be edited under the Document, Production Information and User-defined Fields view. Proceed as follows to edit a User-defined Field:

  1. Select an Order from Order > Order List or Production Job from the menu bar.
  2. Open the Order or Production Job.
  3. Select the Print Item tab or the Order Information tab.
  4. Navigate to the Document, Production Information and User-defined Fields view. In this area, the same Edit User-defined Fields button opens the Edit User-defined Fields dialog (Figure 11), where you can edit the fields.

Inherit characteristics of User-defined Fields

When a Production Job is generated from an Article, the User-defined Fields of the Print Item are also displayed in the Production Job. If the reference is separated between the Article and the Production Job, the User-defined Fields are removed. User-defined Fields for an Article and a Production Job are handled separately.

Order

User-defined Fields for an Order can also be edited by clicking on the Order Information tab under the User-defined Fields tab. To edit these User-defined Fields proceed as follows:

  1. Select Order > Order List from the menu bar.
  2. Select an Order.
  3. Switch to the Order Information tab.
  4. Select the User-defined Fields tab.
  5. Activate the Edit User-defined Fields button. The familiar Edit User-defined Fields dialog (Figure 11) for editing User-defined Fields opens again.

Production Job

The User-defined Fields of a Production Job can also be edited under the Edit User-defined Fields tab. Proceed as follows to edit the User-defined Fields:

  1. Select Production Job from the menu
  2. Open a Production Job
  3. Select the User-defined Fields tab in the Production Job.
  4. Click on the Edit User-defined Fields button. The familiar dialog (Figure 11) for editing User-defined Fields opens again.

2.2.4. Searching for User-defined Fields using Lists

As soon as User-defined Fields have been created in the Workflow, they are immediately available in lists as additional fields. To display User-defined Fields in the list and to search for specific content in User-defined Fields of an Article, proceed as follows:

  1. Select Article > Article List from the menu bar.
  2. In the burger menu of the list header, all new User-defined Fields are available for selection. By selecting a field, it can be displayed anywhere in the list.
  3. To search for the content of a User-defined Field, activate the User-defined Field [47] that you want to search for in the filter bar in the dropdown menu of the search field [46].

Figure 12: The Article List with an open drop-down menu displaying fields to be searched.

2.2.5. Applying User-defined Fields in Reports

User-defined Fields are available for various applications within the Workflow, but can also be leveraged when creating Approval and Ink Cost Reports. By default, User-defined Fields are not used in Reports. If User-defined Fields are needed in a Report, a Custom Report needs to be created first. Please refer to Release Notes 1.2, section 6 for a guide on creating Custom Reports.

If a Custom Report already exists, User-defined Fields can also be inserted in the Report. Follow these steps:

Inserting User-defined Fields in Reports

To insert a User-defined Field in a custom Report, you must first open the InDesign file, extract your desired User-defined Fields from the PrintItemReport_Library, and place them in the desired location within the layout. Proceed as follows:

  1. Connect to the Workflow Workstation (SMB).
  2. In the file directory, navigate to the \\D\PMS_DATA\reports folder where all Report Templates are stored.
  3. Open the current Report Template (without a version number) in Adobe InDesign CC (version CC 2018 and newer). The template is shown in Figure 13.
  4. Open the file PrintItemReprt_Library, which is located next to the Report Template [48]. The InDesign library contains all available fields or variables that can be placed in a Report and finally displayed. This version also includes two differently formatted placeholders for User-defined Fields [49].
  5. Place your User-defined Field placeholders as needed [50] in your Custom Report.

Figure 13: The InDesign template with User-defined Fields added.

Only use User-defined Fields for Print Items and Articles

Only place User-defined Fields that have been added to an Article and/or Print Item table. Currently, only these fields can be displayed in the Reports.

Editing a User-defined Field in a Report

In order to display the desired content of a user-defined field in the report, the corresponding keys must be entered in the script labels for the respective field. To do this, proceed as follows:

  1. In InDesign, select Window > Utilities > Scripts > Script Label [52].
  2. Select your desired text field [55] of a User-defined Field.
  3. Write the key [53] of the User-defined Field in lower case letters in the input field of the Script Label panel. The key refers to the value that you used for the User-defined Field when creating the field - see Figure 5.
  4. Add cf_ at the beginning of the key.
  5. Give the label a name for the User-defined Field (left text field) [54] - matching the key.
  6. Repeat steps 2 through 5 until all desired User-defined Fields have been created.
  7. Then run the export2pdfChip_ppd.jsx script, which can be found in the InDesign Scripts Panel [51], to export the Report.
  8. Load the custom Report back into the Workflow (see Release Notes 1.2 under item 6.3 - step 3).

Figure 13: Editing User-defined Fields in the InDesign Report Template

2.3. DXF-Export for Esko Kongsberg Cutting Devices

In this release we've added the possibility for the Esko Kongsberg cutter to export output files as HPGL or DXF files or in both formats. Generated DXF files contain all necessary data for further processing on the cutting device. These DXF files can then also be opened and edited in CAD programs such as VPack. A description of this process is as follows:

  1. Select the Administration > Cutter Devices
  2. Create an Esko Kongsberg Cutter in the Workflow [56], or select an existing one.
  3. Select either the automatically generated Parameter Set or create a new one [57].
  4. In the third panel under Parameters [58] you will find the option Cutter File Type [59].
  5. Edit this parameter using the Edit button [60].
  6. Use this configuration in the Send to Printer dialog in a Production Job.
  7. The selected Cutter File Type is transferred to Cutting Device.

Figure 15: Managing the ESKO Kongsberg Cutting Device in the Workflow.

2.4. Rest-API

With the update of 1.7.3 we have extended the functionality of the Rest API.  Currently, the following activities - all new functions are marked with (New) - can be mapped to the Rest-API:

  • Creating Customers with Contact Persons and Addresses
  • Create Articles with all available metadata
  • Creating Collections (New)
  • Create Orders with multiple Order Items and several Print Items per Order Item plus all metadata for the Order
  • Create Production Jobs plus all metadata for the Production Job
  • Transferring Data in existing User-defined Fields (New)

A complete documentation of the Rest API can be found under the following link here.

The Rest API is a paid add-on module

Note that an ERP/MIS system connection using the Rest API is not available by default. Users who want to connect the Workflow to an existing ERP/MIS system must meet the following prerequisites.

  • An installed version of Create+
  • A purchased version the Rest-API Module
  • Clarify whether the ERP/MIS system offers a Rest Interface
  • Provide integration resources on the customer side or clarify with us whether these resources need to be provided by us.

If the ERP/MIS system does not provide a Rest Interface, the additional module Rest API should not be used. In this case, Integrate, a middleware that can generate a format that can be interpreted by the Workflow from any input format, should be used. If this is the case, please contact us.

2.5. Manual Impose Mode

In the course of release 1.7.3, the Manual Impose Mode has also been revised. Some functions have been completely reimplemented, other functions – particularly for Print Items with Bleed – have been improved.

2.5.1. Adding a Margin

Until the release of 1.7.3 the user couldn't add a Margin when using Manual Impose Mode. We've added the ability to add Margins to all sides of a Print Item or for individual sides. This is essentially the same function that is used for Rule-based modes such as Nesting and Step & Repeat.

To add a Margin take the following steps:

  1. Select the Production Job menu item
  2. Open a Production Job
  3. Activate the Impose tab
  4. Select Manual Mode.
  5. Before adding Print Items to the Artboard, define a Margin [63] under the Manual Settings tab [61].
  6. Add your Print Items to the Artboard.
    Print Items
    are placed at the top left corner of the Margin [62] by default, rather than the top left corner of the Artboard. As long as Print Items are not manually moved outside of the Margins than Print Items will be placed inside the Margin by default unless there isn't enough space for the Item.

Figure 16: With Manual Mode selected we can now apply Margins to our Artboard as needed.

Trimming the Sheet in Manual Mode

When trimming the Sheet either by selecting Fit to Substrate, Trim to Width and Trim to Height, the Margins are now taken into account. This ensures that the Margin is included when trimming.

2.5.2. Placing Print Items

In this version, adding Print items in Manual Mode has also been revised and improved. There are two main differences:

  • Improved filling available spaces when adding Print Items: If in the previous version the position of the last Print Item added was saved and any additional Print Items that were added, were placed exactly after the previously placed Item, the current version tries to find free space on the entire Sheet in order to place additional Print Items. In other words, as soon as enough free space is found between placed Print Items, free space is filled with new Print Items.
  • The number of copies is automatically added: If you have only added the number of copies that fit on the available space on the sheet, version 1.7.3 will add the specified number of copies, even if this means that Print Items must be placed outside the Sheet [66]. In other words, clicking the [+] symbol [65] automatically places as many Print Items on the page as are entered under Copies [64].

To delete Print Items that have been placed completely outside the Sheet, use the Select Print Items outside sheet size [63] function. Clicking this icon selects only Print Items that lie outside of the Sheet, which you can then delete by pressing the Backspace key.

Figure 17: The Select Print Items outside sheet size function is now available with 1.7.3

Select Print Items outside the Sheet

Print Items outside the Sheet area are only selected if they are completely outside the Sheet. Print Items that are partially on the edge of the Sheet are clipped when saved or printed.

Place one Print Item only

When you click the [+] symbol [65], the number of Print Items automatically placed on the page is the number specified under Copies [64]. However, if you only want to add a single Print Item, you must also hold down the [Alt] key when clicking the [+] symbol.

2.5.3. Rotating multiple Print Items

The Rotation function has also received and update with the release of 1.7.3.

  • You can either select and rotate Print Items as a group
  • You can select and rotate Print Items as a individual items

Figure 18: Below we see the original position of the Print Items before being rotated.

Rotate Print Items on their individual axis

To rotate selected Print Items 90° clockwise around a center axis point, proceed as follows:

  1. Open a Production Job with multiple Print Items
  2. Select the Impose tab
  3. Choose Manual Impose Mode.
  4. Place multiple Print Items on the Artboard, arrange the Print Items as needed, similar to Figure 17
  5. Select all Print Items [CTRL] + [A] or by selecting them by using [CTRL] + [Left Mouse Click].
  6. Define the Pivot Point [68] under the Transform panel [67].
  7. Click on the Rotate Clockwise button [69]. You can see the result in Figure 18.

Figure 19: The individual Print Items after being rotated on their individual axis.

Rotate Print Items as a group

To rotate Print Items as a group 90° clockwise around the center point, proceed as follows:

  1. Open a Production Job with multiple Print Items
  2. Select the Impose tab
  3. Choose Manual Impose Mode.
  4. Place multiple Print Items on the Artboard. Arrange the Print Items as needed, similar to Figure 18.
  5. Select all Print Items using [CTRL + A] or by selecting them with [CTRL + Right Mouse Click].
  6. Define the Pivot Point [71] under the Transform panel [70].
  7. In addition to the normal Rotate functions, you can activate the Rotate as Group checkbox [73].
  8. Click on the Rotate Clockwise button [72]. You can see the result in Figure 19.

Figure 20: The individual Print Items after being rotated as a group.

2.5.4. Handling Bleed in various Impose Modes

In previous versions there were various problems that occurred when changing the Bleed of an Item. After carrying out certain functions - such as rotating and scaling, input fields for the Bleed were deactivated. When this happend, it was no longer possible to change the Bleed. We have now standardized the way Bleed is handled in the Impose Editor and made the behavior when adding Bleed in connection with other functions more consistent. The following issues have been updated:

Handling the Bleed after scaling a Print Item

In previous versions the input fields for Bleed were locked after changing the Scale of the Print Item. In version 1.7.3 (see Figure 20) the Bleed behaves as follows:

  • The Bleed is Scaled together with the Print Item (visually)
  • In the input fields of the Bleed, the values do not change after Scaling.
  • Bleed can be changed again after Scaling.
  • Since the Scaling factor is displayed anyway, it is also logical that it applies to the Bleed.

Figure 21: Schematic representation of how the Bleed changes during scaling

Bleed with Scaling applied - 1.7.3

Handling the Bleed after rotating a Print Item

With Rule-based Impose Modes, Bleed is not rotated with the Print Item. In Manual Mode, Bleed is rotated with the Print Item. In previous versions, Bleed input fields were locked after Rotating a Print Item and the Bleed could not be edited afterwards. In version 1.7.3 the Bleed behavior has been changed:

  • The Bleed and the Print Item are rotated together.
  • In the Bleed input fields, the values are not changed or »rotated«.
  • The Bleed can be edited after being Rotated.
  • Since the Rotation value is displayed the user can assume that it also applies to the Bleed.

Figure 22: Schematic representation of how the Bleed is displayed after rotation.

Bleed with Rotation applied - 1.7.3

Handling Bleed when switching to Manual Mode

With Rule-based Impose Modes, Bleed is not rotated with the Print Item. In Manual Mode, Bleed is rotated with the Print Item. (see Figure 22). If in previous versions you switched from Rule-based Mode to Manual Mode, the Bleed input fields were locked. The Bleed could not be edited afterwards. In version 1.7.3 the Bleed has the following behavior when switching Impose Modes:

  • The Bleed of the Print Item is not rotated after switching to Manual Mode.
  • In the Bleed input fields, the values are changed or "rotated" so that they match the displayed Print Item.
  • The Bleed can be changed any time.

Figure 23: Schematic representation of how the Bleed is rotated in Step & Repeat mode and how the Bleed is displayed after switching to Manual mode.

2.5.5. Cropping Print Items with Bleed

With 1.7.2, we implemented the ability to Crop Print Items in Manual Mode, the exisiting Bleed was simply ignored during when Cropping an Item. With version 1.7.3 this behavior has been updated, so that the Bleed is now preserved when Cropping.

You can Crop a Print Item with a Bleed as follows:

  1. Open a Production Job with a Print Item that has a Bleed.
  2. Click on the Impose tab.
  3. Choose Manual Mode, and the Impose Editor will activate Manual Impose Mode.
  4. Place your Print Items on the Artboard. The values for the Bleed are displayed under the Bleed panel.
  5. Use the Selection tool [74] to select your Print Item.
  6. Activate the Crop tool [75] in the toolbar. A Cropping mask [76] is placed over the TrimBox. The Cropping mask offers eight points which can be moved freely with the mouse. In addition to the Cropping mask, the defined Bleed is also displayed as a red semi-transparent shape [77].
  7. Drag the Cropping mask to your desired dimensions. By dragging a point, the cropped areas of the Print Item are dimmed. The visible area of the Print Item represents your crop result. The entered value for your Bleed in the Bleed panel of the Print Item moves with the Cropping mask. As soon as the Print Item has been cropped, the TrimBox including the Bleed value is visible in the Bleed panel.

Figure 24: Below we can see the Cropping tool in combination with the TrimBox and Bleed being updated live as we crop a Print Item.

If Bleed is not needed

If the Bleed should be Cropped or ignored during Cropping, the Bleed must be set to 0 or removed before Cropping.

3. General Improvements

3.1. Nesting with Print Items of different dimensions

In previous versions, it wasn't possible to define Spacing between Print Items when Nesting with Print Items of different dimensions. This function has been updated and works as follows:

  1. Open a Production Job with several Print Items of different sizes.
  2. Click on the Impose tab
  3. Select Nesting Mode. If there is enough space, all Print Items contained in the Production Job - are automatically Imposed. A Spacing of 3mm is applied by default. This Spacing can then be overwritten or changed.
  4. To do this, open Nesting Options [78] under the Artboard Settings panel.
  5. Enter Horizontal & Vertical Spacing [79].

Horizontal and Vertical Spacing influence Nesting

Note that entering a horizontal or vertical space between Print Items can affect the geometry of the Imposition and/or the number of Print Items placed.

Figure 25: Horizontal and Vertical Spacing options available in Nesting Mode with Print Items of different dimensions.

3.2. Color Setup

Two areas in the Color Setup menu item have been revised. We have improved new features that were implemented in version 1.7.2. We have improved the display of the measurement data within the analyze step and also updated the behavior when selecting either white over/under print in the Print Configuration settings.

3.2.1. Display of measurement data in the Anaylze dialog

In version 1.7.2, realtime previews of measurement data during the measurement was implemented. This preview shows the reference values and the values currently measured. In version 1.7.3, the reference values are now displayed in addition to the measured values even after the profiling calibration chart has been calibrated.

  1. Create a new Color Setup
  2. Carry out all Profiling steps up to the point where you measure the Profile Calibration charts
  3. Completely measure the Profile calibration charts
  4. Open the Analyze Profile dialog [80]. With the new Analyze Profile dialog, the reference values (above) and the current values measured (below) are displayed. Due to the difference between Inks from different printing systems and Substrates, distinct differences between reference values and measured values can be perceived. Future releases will try to adjust the reference values so that they better represent filled Inks and the Substrate used.

Figure 26: The Analyze Profile dialog as seen when all Profile charts have been successfully measured.

Large differences between Reference and Measured values

At the moment only the CMYK reference values are displayed correctly. The color space-expanding colors (Orange, Violet, Green,...) are currently ignored in the reference values and are not included in the color preview. Thus, as soon as CMYK values are "0" and color space-expanding colors are present, the reference values are displayed as white patches, but the measured color values are displayed correctly.

3.2.2. Display of White Options depending on Printer Type selected

As with the previous version 1.7.2, the Workflow offers the possibility to add a White background or foreground to calibration charts. Due to variances in current printing systems, the selection of these two options was limited:

  • If the selected Printer is capable of adding a White process color, the Add White Background function is available.
  • If the selected Printer has a White Over (s2) color added, the Add White Foreground function is available.
  • If the selected Printer has both options White & White Over (s2), both functions are available.
  • If neither of the two colors exist, both functions are deactivated.

These two functions can be selected for all Calibration Chart print dialogs, as long as the necessary colors are available.

3.3. Printer Type Parameters

When creating a new Printer or a new Print Configuration, it was often possible to select parameters that are not available for that Printer. This could lead to misconfigurations. In order to eliminate this problem, we've implemented some new parameters - depending on the Printer Type - i.e. Printers that are not adjustable or already pre-filled. The following parameters were either deactivated or enabled:

3.3.1. Support for Backlit options

Some Printers and/or Print Configurations support Backlit features - others do not. Despite this compatibility issue, all available Backlit options were able to be selected, regardless if the selected Printer supported this function or not. With version 1.7.3, Backlit options are now enabled or disabled when creating a Print Configuration, based on the selected Printer Type:

  • If the Backlit feature is not supported by the selected Printing system, all Backlit options will be deactivated.
  • If the selected Printing system supports Backlit features, at a minimum Backlit Process Colors will be available.
    • If a White Process Color is available, Backlit White Underprint can be selected.
    • If an additional White Over Process Color is available, then Backlit White Overprint can be selected.
    • If neither of the two process colors are available, both Backlit functions are deactivated.

3.3.2. Standard Render Engine and Dither Mode

Version 1.7.3 also has enabled a feature where the Render Engine and possibly a Dither Mode are pre-selected by default so that users no longer have to re-select them each time a new Print Configuration is made. All pre-selected settings can be subsequently adjusted by the user as needed:

  • Label Printers use the Standard Render Engine without a Dither Mode selected by default.
  • LFP and CPD Printing systems use the Harlequin Host Renderer with AIS Dither Mode by default.

3.3.3. Support for Finishing Options

Some Printers and/or Print Configurations support finishing options (matt/gloss) - others do not. Previous to this release, all finishing options could be selected, regardless of whether the Printer supported this feature or not. Version 1.7.3 now unlocks or completely disables finishing options when creating a Print Configuration, depending on the Printer Type selected.

3.4. Role Permissions

In the course of this release, numerous changes were made to the available Role Permissions. New options are also available for assigning Permissions to a Role.

3.4.1. New Role Permissions

The following Permissions have been added:

  • Administrate Measurement Devices – Access under Administration > Measurement Devices
  • Downloading Color Books – Click the download button in the List of Color Books
  • Print Color Books – Can be accessed in the Send to Printer dialog, in the action bar Color > Color Book & Grid Charts under the Color Books tab
  • Permission to create Grid Charts – Access using New in action bar under Color > Color Book & Grid Charts under the Grid Charts tab
  • Permission to delete Grid Charts – Access using Delete in action bar under Color > Color Book & Grid Charts under the Grid Charts tab
  • Downloading Grid Charts – Click the download button in the Grid Charts List
  • Print Grid Charts – Can be accessed in the Send to Printer dialog, in the action bar Color > Color Book & Grid Charts under the Grid Charts tab
  • Permission to create Color Setups – Access using New in action bar under Color > Color Setup
  • Permission to delete Color Setups – Access using Delete in action bar under Color > Color Setup
  • Permission to duplicate Color Setups – Access using Duplicate in action bar under Color > Color Setup
  • Permission to edit Color Setups – Access using Edit in action bar under Color > Color Setup
  • Download Print Item & Technical Colors – Access using Download Item > Print Item & Technical Colors
  • Split Article reference – Access under Production Job > Split Article Reference in the action bar

3.4.2. Deleted Permissions

The following permission have been deleted:

  • Edit Color Books – Color Books have to be created individually. Editing Color Book was never possible.

3.5. Inks

In the course of this release, new Ink Families and Inks were added, which are commonly used in the American market. These new Inks can be found under Administration > All inks.

Table 2: New Ink Families are available in the Master Data

Ink Family Ink 
Dru Ink Cyan, Light Cyan, Magenta, Magenta HD, Light Magenta, Yellow, Black, Orange, Violet, Green, White
RHO AP Ink
Cyan, Light Cyan, Magenta, Light Magenta, Yellow, Black
P5 DRU Ink
Cyan, Light Cyan, Magenta, Light Magenta, Yellow, Black

3.6. Fixups

Improvements have been implemented that allow Fixups to be automatically formatted and displayed when uploaded to the Workflow. Fixups are only available with the Create and Create+ licenses. Three new and/or improved Fixups are explained in further detail below.

3.6.1. Redye CMYK-Objects

This Fixup can be used to Redye Text and Vector Objects. When applying this correction, the original CMYK Source Colors [82] must be entered first. You can then specify the Target CMYK [83] to be used. This correction can be applied to the following CMYK objects [82]:

  • Text
  • Vectors
  • Text & Vectors

Figure 26: Applying the Fixup Redye CMYK-Objects

Redye CMYK-Objects Fixup - 1.7.3

3.6.2. Split single page print item into pages with given height

Some printing systems cannot print motifs that are longer than a defined height. For this reason, a Fixup has been made that splits the design into multiple pages of a specific height [84].

The working method could be as follows:

  • The operator uploads a 4.5 m in length Print Item to the Workflow.
  • The Fixup divides the Print Item into X pages, whereby no page may be longer than e.g. 100 cm.
  • The result is a multi-page motif with 9 pages (each page is 50 cm long).

This Fixup can also be located under the Data Preparation tab.

Figure 28: The Split single page print item into pages with given height Fixup

Split single page print item into pages with given height - 1.7.3

3.6.3. Derive a PageBox from Colored Objects

This Fixup existed in previous releases. In previous versions, when applying this Fixup, only the TrimBox could be reset based on specified colors. This correction has now been extended by adding additional options. With Release 1.7.3, you can select which Pagebox frame is to be reset when applying the correction. The following page geometries can be reset:

  • TrimBox
  • BleedBox
  • CropBox
  • MediaBox

3.7. PDFChip 2.0

Version 1.7.3 contains the latest version of PDFChip, the application that is responsible for creating the Imposition Data and multipage PDF files for variable data printing. In addition to many improvements, the following points deserve further emphasis:

Enormous speed increase in the processing of variable data: The creation of multipage PDF files with variable data can now be rendered up to a factor of 100 times faster.

Increased Imposition accuracy: Whereas slight inaccuracies in the millimetre range could previously be detected, especially with longer Impositions, it is now possible to carry out an Imposition where any inaccuracies are no longer discernible.

4. Bug Fixes & Minor Details

4.1. Workflow

Update PDFToolBox 10.1.490: A new version of Adobe PDF Converter has been integrated (PostScript conversion to PDF).

DeviceN Spot Colors: No color previews of DeviceN Spot Colors were being displayed in Print Item view. This bug has been fixed (DW-1169).

Create Production Job from Article: The ability to select an Impose Mode & Template was causing a Stacktrace (DW-1164).

Calibration Chart Measurement Previews: The color preview of the measured calibration charts was not correctly updating when switching between pages (DW-1039).

Editing Production Job status: When changing the status of several Production Jobs using the Edit settings, not all settings were saved correctly (DW-1058).

Ink Overview: Some Tooltips for individual inks were displaying incorrectly. (DW-1153).

Applied Inks: The page numbering function for aaplied Inks was not working correctly (DW-1134).

Print Configuration: When a Print Configuration with a selected Parameter Set is saved, the selected Parameter Set for the Print Configuration is also saved (DW-1215).

Download Print Item: When downloading Print Items and Impose output files, this dialog will stay openfor the entire duration of the download process  (DW-1213).

Production Jobs without a Color Policy: When opening the Send to Printer dialog, an error message is displayed if no Color Policy is selected (DW-1210).

Offending Command - setpagedevice: When sending to the printer, white channels are ignored if the file does not contain white (ZCM-1114).

Spot Color definitions: When creating a new Spot Color definition and assigning it to Library or System for example, it will not be automatically selected after saving (DW-1191).

Change Color Policy: If the Color Policy was changed in the output configuration of a Production Job, the old Color Policy was still selected in the Send to Printer dialog (DW-1190).

New Calibration Charts: Calibration charts for the color configurations CMYKOVlk & CMYKRBG were added to the Workflow (DATA-110 & DATA-109).

Role Permissions: Some checkboxes were not selected correctly when all underlying checkboxes were activated (DW-1184).

Create Technical Colors: When converting a Spot Color to a Technical Color, the CutContour type is preselected by default (DW-1183).

DeviceN Spot Colors: The DeviceN Spot Color previews were sometimes calculated and displayed incorrectly (DW-1169).

Lead-in & Lead-out: A lead-in and a lead-out can be defined (DW-1165) in the Create Production Job from an Article dialog.

Impose Templates: No Impose Templates could be selected in the Create Production Job from an Article dialog without an error being displayed (DW-1164).

Collections: Create Order or Production Job was available in the process drop down after creating a Collection with no Articles assigned to it. (DW-1156).

Default Check-in profile: If a user-defined Check-in profile and set it as default, the new default Check-in profile was not being recognized (DW-1150).

Hotfolder list: Hotfolders now have an ID Number assigned to them and can be searched for in the search criteria list (DW-1124).

Substrate Distortion: Substrate Distortion was not being applied when 100% was selected (DW-1116).

Hotfolder Preview: Hotfolder Job preview was not visible in Job List when Step & Repeat mode was selected (DW-1061).

Color Correction: DeviceN color corrections can only be selected if a CMYK & CMYK+light color configuration has been selected (DW-692).

Rendering Intents: Can only be selected if a CMYK & CMYK+light color configuration has been selected. All CMYK+ color configurations use the default rendering intent Perceptive (DW-1258).

4.2. Impose Editor

Marks: If several Marks of the same type were added, the settings from the first Marks were overwritten by the next set of Marks (IMPOSE-489).

Mark Color: Different Mark colors for Marks of the same type were not supported. Each Mark can now be defined individually (IMPOSE-464).

BleedBox after Cropping: After cropping a Print Item, the BleedBox was displayed incorrectly (IMPOSE-447).

Scale: The Fill button was only Fitting the Print Item to the substrate, after clicking the button a second time it would Fill the Substrate correctly (IMPOSE-469).

BleedBox after changing Impose Mode: After switching from Rule-based Mode to Manual Mode, the BleedBox was displayed incorrectly (IMPOSE-466).

Scaling + Marks: After scaling in Manual Impose Mode, Marks were placed incorrectly (DW-830).

Scale to Substrate: The two options Fit to Substrate & Fill in Manual Impose Mode were reversed (DW-1181).

Rotation + Marks: After rotating Print Items with a Bleed, the Marks were placed incorrectly. This bug has been fixed (IMPOSE-499).

Imposing Print Items over 10 meters in length: Imposing Print Items over 10 meters in length now possible (IMPOSE-310).

Impose Templates: After creating and saving an Impose Template it was locked by default. Templates are unlocked by default now (IMPOSE-556).

4.3. Adobe Illustrator Plug-in

Output as Separation: If the option "Output as Separation" option is activated in the Spot Color Management of the Plug-in, a Process Color must also be selected (PXT-734).

Saving VDP Data: Saving a File locally including at least two different types of Variable Data will crash Illustrator after reopening. This bug has been fixed (PXT-783).

Variable text with Special Characters: When entering special characters in a VDP Barcode or Text a warning will now appear (PXT-774).

4.4. Hot Fixes

Impose Mode Step & Repeat: When rotating Print Items, the items had a slight offset in the Impose Editor, but the render output was correct. This bug has been fixed. (New version: User Interface Impose Editor 1.7.3-1).