
Creating Third-party Printers 

Administration > Interfaces 

Availability: all versions with a multi-line license 

1. General 

Third-party printers are controlled in the Workflow based on the printer drivers provided by PrintFactory. It should 

be mentioned that all functions concerning color management, imposing, rendering and screening are mapped by 

the functions in the Workflow, and the output file, which is normally created for printers that are directly controlled, 

is only converted for output to the third-party printer and the required job ticket is created. 

This implementation ensures that consistent quality in terms of color management and screening can be 

guaranteed when outputting a print itme, and also ensures that operators don't need to change their working 

methods when outputting data to third-party printers. 

The following requirements must be met so that third-party printers can be controlled by the Workflow: 

• Print Factory License – This is provided when purchasing a multiline license (driver). 

• Print Factory Installation File – The Print Factory - Durst Edition installer is provided. 

• Driver availability – Third party printers can only be controlled if the corresponding driver is available using a 

valid version of the PrintFactory printer software. 

• Durst Workflow Installation Setup – The Workflow installer is provided. 

• Durst Workflow license with a multi-line license for third party printers – The license file with the appropriate 

permissions will be provided after purchasing the license. 

Once these boxes have been checked, you can start the installation process. 

2. Installing and Configuring Print Factory 

In order for the Workflow to redirect output to a third-party printer, the required Print Factory software components 

must first be installed and the driver and license for the printer must be activated. To do this, proceed as follows. 
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2.1. Downloading and installing Print Factory 

1. Download the installation file for Print Factory from the following link: https://service.prepress-digital.com/

Various/PF640.10507.msi 

2. Install the software on the same workstation where the Workflow will be installed. 

3. During the installation, you must activate the license that you received in advance. 

4. After the installation is complete, restart the workstation. 

2.2. Configuring Print Factory 

Once Print Factory has been successfully installed, you can proceed with installing and configuring the printer. 

Proceed as follows: 

1. Start the Print Factory software by double-clicking on the PrintFactory RIP shortcut on the desktop. 

2. Open the General tab under the RIP > Preferences (for MacOS) or Edit > Preferences (for Windows). 

3. In the Work Folder [1] section, select the D:/Work folder, this must first be created using Windows File 

Management if it is not already available. Close the dialog by clicking OK [2]. 

Figure 1: The General tab under the Preferences dialog. 

Installing Print Factory on another workstation 

Note that the Print Factory installation can also be installed on another workstation, provided that it 

is on the same network. Refer to the Render Satellites - ZuniComm article for additional instructions. 
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3. Then add the desired printer. To do this, call up the menu command File > Output Device > New. 

4. In the Browser tab [3], select the desired printer from the list and enter the information required to establish a 

connection to the desired printer under the Connection area [4]. 

Figure 2: The Browser tab visible under the Output Device dialog from Print Factory. 
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5. Close the dialog by clicking OK [5]. You have successfully set up the printer. The printer should now be available 

in the list of configured printers [6]. 

Figure 3: The PrintFactory RIP interface with two areas: the printer list and job name. 
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2.3. Additional Windows Settings 

Before the third-party printer can be created and/or configured in the Workflow, the correct permissions must be 

enabled in Windows. The folder called »Work« d:/Work must be shared. Proceed as follows: 

1. Open Windows Explorer and locate the d:\ [7] hard drive. 

2. Select the folder called d:\Work and open the Properties for this folder. 

3. Switch to the Sharing [8] tab. 

4. Click on Advanced Sharing [11] . 

5. In the Advanced Sharing dialog, activate the option Share this folder [9]. 

6. The Share name must be called »Work« [10]. 

7. Click on Permissions [13]. 

8. Activate Full Control [12] for Everyone [14]. 

9. Save your settings and close all windows to complete the process. 

Figure 4: Various dialogs in Windows showing how to share the Work folder. 
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3. Configuring Third-party Printers in the Workflow 

After the third party printer has been successfully created in PrintFactory and the Share has been correctly set up in 

Windows, third party printer(s) can now be created in the Workflow. 

3.1. Setting up the Host 

In order for the Workflow to transfer ripped files to PrintFactory, a Host for the Work folder must be added in the 

Workflow. Proceed as follows: 

1. Log in to the Workflow. 

2. Navigate to Administration > File Management. 

3. Add a new Host for PrintFactory 

• Enter a name for the PrintFactory Host. 

• Select Third-party Printer in the Type drop-down. 

• Under Host, enter the IP address of the Workflow. If PrintFactory is installed on the Workflow workstation, 

then 127.0.0.1 can be used. 
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• Add the SMB User by entering the Username and Password of the Workflow workstation which has access 

to the »Work« Folder for PrintFactory. 

• Save the dialog to continue. 

Figure 5: The Add Host dialog, where the user can add a new Host for the PrintFactory instance installed on the 

Workflow workstation. 

4. After the Host has been saved, a new Share must be created. 

5. To do this, click the New button in the footer of the Shares panel. 

6. Select the Work folder in the dialog. 

7. Save by clicking on OK. 

Figure 6: The File System Navigator dialog, where shared directories are listed and a new Share can be added. 
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Registering the Printer Instance in the Workflow 

After setting up the Host and Share, the third-party printer instance must be registered in the Workflow. Proceed as 

follows: 

1. Navigate to Administration > Interfaces. 

2. Select the Third-party Printer tab. 

3. Click on + New in the action bar. The Add Third-party Printer Instance dialog will open. 

4. The following settings can be entered in this dialog: 

• Name – Assign a descriptive name for the printer instance. 

• Host / Port – Enter the IP address of the workstation where PrintFactory is installed. If the instance is 

installed on the Workflow workstation, you can use 127.0.0.1. The default port is 9200. Press the Test 

Connection button [15] to test if the connection can be established. If an error occurs, check the previous 

steps again and if it still fails, contact customer support. 

• Host – Select the previously created Host where Production Jobs must be sent. 

• Source – Select the previously created Share where the third party printer will source the production data. 

Figure 7: The Add Third-party Printer Instance dialog, which completes the registration process in the Workflow 

when connecting third-party printer instances. 
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Add a Third-party Printer in the Workflow 

After successfully completing all of the above mentioned steps and when the printer instance for the third-party 

printer has been created, you can add the printer and its respective print configurations in the Workflow. Proceed as 

follows: 

1. Navigate to Administration > Printer. 

2. Click on + Third-party Printer in the action bar. 

3. Follow the steps in the dialog to add the printer. 

Step 1 – Printer 

1. Using the Instance drop-down, select the desired printer instance. 

2. Select the Printer Type in the drop-down list. The list of available printer types is provided by the printer 

instance. Only printers which are licensed by PrintFactory will be available. 

3. Enter a Name for the printer, this name will be used later in the Workflow, e.g. when configuring your Output 

Templates. 

4. The additional options that are listed are optional. Some printer types provide this information. 

5. Click Next to access the next step. 

Figure 8: The Add Third-party Printer dialog when setting up a third-party printer. 

User Manual

Page 9Creating Third-party Printers



Step 2 – Printer Media Mode (PMM) 

1. Select the desired Media as well as the Print Mode (GUID).  Please note that the setting options provided by the 

third-party software may vary depending on the Printer Type selected in the previous step. Configurations from 

Print Factory are shown, if any are available. 

2. Click Next to start the next step. 

Figure 9: The Add Third-party Printer dialog showing the Print Media Mode (PMM) step. 

Expert Mode 

In Expert mode, the user must manually select all print configuration parameters and find a working 

combination. 
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Step 3 – PMM Configuration 

In this step define any additionally needed configurations for the Print Media Mode. 

Figure 10: The Add Third-party Printer dialog showing the PMM Configuration step. 
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Step 4 – Print Configuration 

After all printer-related parameters have been set, define render-specific parameters: 

1. Enter a name for the Print Mode, which will subsequently be displayed in the Workflow. 

2. Check any options needed in this dialog and change desired parameters if necessary. 

3. Click on Save to create the third-party printer in the Workflow. 

Figure 10: The Printer & Print Configuration dialog, showing the General Print Configuration step. 
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The printer is now available in the Workflow using the entered Printer Configuration. For the operator, printers from 

third-party manufacturers can be controlled in the same way as Durst and Vanguard printing systems. 

4. Additional Printer Configuration Settings 

If you have created a third-party printer in the Workflow with a Print Configuration, the next step is to create the 

necessary Print Configurations for production work. Proceed as follows: 

1. Navigate to the Administration > Printer Setup. 

2. Select the desired third-party printer from the Printer list. 

Activities performed in the background 

When the dialog is saved, the printer is created in the background applying all settings in the 

Workflow. For example: Inks, Drop Sizes, Print Color Configuration and the Color Configuration are 

created and mapped.  
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3. Double-click on the entry. Three panels: Color Configuration, Channel Configuration and Print Configuration are 

displayed. 

4. To create an additional Print Configuration, click on + New in the footer of the Print Configuration panel. 

5. Repeat step 2 and 3 as previously described. 

Article update: for Workflow Version 1.15.0 

Why is it not possible to create a Channel Configuration? 

Channel Configurations are part of the Print Configuration for third-party printer manufacturers. 

Therefore, when creating a Print Configuration, the corresponding Channel Configuration is 

automatically created in the Channel Configuration panel. 

What settings can be changed in the Color Configuration panel? 

You can store the ink which is used in this settings panel. When you create a third-party printer, an 

Ink Family with the corresponding Inks are automatically created. For the sake of traceability, you 

should create the Inks as well as the Ink Family in the Workflow and then assign them correctly in the 

Color Configuration panel. You can read more about this topic in the article: Create and Edit new Inks. 
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