General Overview

Adobe Illustrator > Plug-In

Plug-In Availability: Durst Workflow Plus or Durst Workflow Label Medium/Large

Static Barcode panel Availability: Paid license for Durst Workflow Plus and Durst Workflow Medium/Large

Variable Data panel Availability: Paid license for Durst Workflow Plus and Durst Workflow Medium/Large

The Workflow offers a Plug-in solution for direct editing of Print Data in Articles, Orders and Production Jobs in Adobe Illustrator. This Plug-in seamlessly connects Adobe Illustrator to the Workflow. In this chapter we'll learn,

  • Which functions are available under the File Management panel for accessing Print Data in the Workflow.
  • How to access individual panels in the Plug-in.
  • Which functions the individual panels have in the Plug-in.

1. General

The Adobe Illustrator Plug-in offers the user the possibility to edit Print Data contained in Articles, Orders and Production Jobs. Instead of having to download existing Print Data from the Workflow, editing them manually and checking them in again, Print Data can be loaded directly into Adobe Illustrator, the edited file can then be uploaded without any intermediate steps. When edited Print Data are checked in, a new version is automatically created in the Workflow.

In addition to directly editing Print Data, i.e. changing the end format, setting a Bleed, or overprinting white channels - you can add Variable Barcodes/QR codes, Images, Shapes or Texts, each defined according to your preferences. Generated data sets such as serial numbers and predefined data bases using CSV files can also be integrated using the Plug-in.

Before harnessing the power of the Adobe Illustrator plug-in, it must be installed first. Information covering the installation of the Plug-in (for both Windows & Mac) can be found in the next article Installation.

2. Set up access

After installing the Plug-in, individual panels in Adobe Illustrator can be accessed after restarting Adobe Illustrator. To access the basic panels, proceed as follows when using them for the first time:

  1. Open the File Manager panel.
  2. Set up the required connections and select your language.
  3. Enter your log in information to access the Workflow.

After logging in, the appropriate panels will be available. Please note: the license you have purchased will dictate which panels and options are available.

Adobe Illustrator's access to the Workflow counts as a concurrent user

Since Adobe Illustrator is a standalone application, the File Manager panel uses a parallel user interface available to you when you log on. By default, Durst Workflow Print users can have up to three concurrent users and Durst Workflow Label Small/Medium/Large users can have up to five concurrent users.

After performing the steps outlined above the Adobe Illustrator Plug-in is ready to use.

2.1. Open the »File Management tab«

Before you begin editing Print Items or accessing other features and panels in the Plug-in, you must log in to the Workflow using the Plug-in. Proceed as follows to accomplish this:

  1. In Adobe Illustrator, select Window [1] > Durst Workflow [2].
  2. This opens a fly-out menu where you can access all panels that are available in the Plug-in.
  3. Select File Management [3], which will open the File Management panel.

Figure 1: Adobe Illustrator menu Window with an open fly-out menu listing the panels contained in the Plug-in.

2.2. Setup the connection to the Workflow and choose your language

After opening the File Management panel, the familiar login dialog from the Workflow is displayed. Before you can log in, you must set up the connection between the Plug-in and Workflow. Proceed as follows:

  1. Open the Settings menu by clicking on the Settings hamburger icon [4] in the upper right corner.
  2. This opens the Settings dialog.
  3. Enter the IP address of the Workflow server [6] and the IP address of the Zunicomm server [7], make sure to enter the port numbers specified in the figure below.
  4. Select the desired Language [5] if needed and change the Auto logout after [8] amount of time if needed, this will automatically log out the user from the Plugin, therefore using one less concurrent user.
  5. Leave the checkbox Add Used Colors 'Swatches' activated. With this option activated, when a Print Item is opened in Illustrator all pre-defined colors will be automatically added to the Swatches panel in Illustrator.
  6. Save the settings by clicking on Apply.
  7. The Welcome dialog should reappear afterwards, this means that the configuration of the Settings panel was carried out correctly and logging in should now be possible.

Figure 2: The File Management panel contains two input fields, enabling the user to log in (right) and various options available in the Settings dialog (left).

Adobe Illustrator Plug-in - Settings panel and Login window

Workflow IP and ZuniComm IP with port numbers mandatory?

While entering the correct IP address and port number is essential for the Workflow to access the Plug-in, the ZuniComm IP and port number is only required when creating Barcodes. If you do not have access to the Static Barcode/Variable Data panels, the Zunicomm IP and port number are no longer relevant.

2.3. Log in to the Workflow

After all Settings have been saved, you can log in with your user account. After a successful log in, you are granted access to the Workflow. Now we can start working!

The user cannot log on to the Workflow

If logging in to the Workflow fails or is not possible, the most common causes are:

  1. You do not have the necessary License.
  2. You have entered the User Account information incorrectly. Username and Passwords are case sensitive.
  3. The port numbers entered were not enabled for your specific computer in the network. If you suspect this is an issue, contact your IT department.

Barcode-Service not available

If the message »ZuniCom Barcode Service not available« appears in the Variable Data or Static Barcode panel, either the: IP address or port number is incorrectly entered in the Settings panel. However, if the IP address and port number are entered correctly, it may be that the port 8989 is not enabled for this computer in your network.

3. Plug-in User Interface overview

Depending on the license installed, the user has access to various panels in the Plug-in. The following description will give you a rough overview of the panel functions as well as some background knowledge about the purpose and operation of these panels.

3.1. File Management

3.1.1. User Interface areas

The File Management panel is the main »operational hub« of the Plug-in which provides the following functions:

  • Define the Settings needed to establish a connection between Adobe Illustrator and the Workflow.
  • Choose or change the display Language.
  • Connecting/disconnecting Adobe Illustrator and the Workflow by logging in/out.
  • Search for Print Items in Articles, Orders and Production Jobs.
  • Create new Production Jobs.
  • Check-in/out Print Data into the Workflow.
  • View the current Status of specific processes in the Workflow.

Without successfully logging in to the Workflow via the File Management panel, other Plug-in panels will not be available. Logging in establishes a secure connection between Adobe Illustrator and the Workflow. This connection is used to access Print Item metadata from Adobe Illustrator as well as to copy files between the Workflow and your local computer.

When a file is checked out, a copy of the Print Item is saved locally to the workstation's hard disk in the Workflow. Any changes that are made and saved in Adobe Illustrator is therefore done locally. The most recently saved local version is transferred to the Workflow when the Print Item is checked in and the local version is then deleted.

The Terms Check-In and Check-Out

The term Check-in is applied when an open file in Adobe Illustrator is saved and checked-in as a new version in the Workflow. The term Check-out applies when a Print Item in the Workflow is opened in Adobe Illustrator.

3.1.2. User Interface

The File Management panel can be divided up into four areas, depending on whether an Article, Order, or Production Job is selected. These four areas cover the following functions:

  • Central Area [9] – This area is used for searching and selecting Print Items, Orders, and Production Jobs, as well as viewing the current status of the connected Workflow. Additionally, Production Jobs can be created and deleted. This area is always available, but the content displayed depends on the menu item selected.
  • Order Item – This area is used for selecting Order Items. This area is only available if Order has been selected in the central area.
  • Print Item [10] – This area is used for selecting individual Print Items. This area is only available if an Order or Production Job has been selected. Print Items displayed in this area are assigned to the selected Order Item or Production Job.
  • Information [11] – This area is used for displaying metadata concerning the selected Print Item, displaying additional information, checking Print Items in and out, and logging out of the Workflow.

Figure 3: The File Management panel with the Jobs menu selected.

Adobe Illustrator Plug-in - File Management panel

Depending on which menu item is selected in the central area, the following areas are available:

  • Articles – contains two areas: the Central Area and Print Data.
  • Orders – contains four areas: the Central Area, Order Item, Print Item and Print Data.
  • Jobs – contains three areas: the Central Area, Print Items and Print Data.

Central Area

In the Central Area, you can select Articles, Orders, Jobs, and Status. If you selected Jobs, you can create, edit and delete a Production Job. The Central Area contains the following items:

  • Search field [12]Articles, Orders and Production Jobs can be searched by specific criteria.
  • Menu bar [13]
    • Article: Displays all Articles that exist in the Workflow (including all Tiles created by the Tiling imposition process).
    • Order: Displays all Orders that exist in the Workflow.
    • Jobs: Displays all Jobs that exist in the Workflow.
    • Status: Displays the System Status and all Activities in the Workflow.
  • Footer [14] – When an Article, Order or Job is selected in the Central Area, the navigation area is located in this footer, where you can view/select the next/previous ten entries of the selected menu. If the Jobs menu is selected, additional functions in the form of symbols are also available:
    • Add: By clicking on the + symbol, you can create a new Production Job directly from the Plug-in.
    • Edit:  By clicking on the Pencil symbol, you can edit an existing Production Job directly from the Plug-in.
    • Delete: By clicking the Trash symbol you can delete existing Production Jobs directly from the Plug-in.

Information on creating a Production Job can be found in the article Creating a Production Job in Illustrator.

Figure 4: The Central Area of the Plug-in with the Jobs menu selected.

Adobe Illustrator Plug-in - File Management

Order Item

The Order Item area is only displayed if the Order menu item has been selected in the Central Area. Four menu items are available in the menu bar of this area:

  • Order Item: This option displays all Order Items that are available for the selected Order.
  • Details: In the future, details concerning the Order Item will be available here.
  • Contact: In the future, Contact Person information pertaining to the Order Item will be available here.
  • Protocol: In the future, the steps logged for the Order Item will be displayed here.

Figure 5: The Order Item area, which is only displayed in the Central Area when the menu item Order is selected.

Adobe Illustrator plug-in - Order Item area

Print Item

All Print Items belonging to an Order Item or Job are displayed in the Print Item area. When you select an Print Item, metadata is displayed in the Information area. The Print Item can also be Check-in/out here as well.

Figure 6: The Print Item area is only displayed when either the Order or Jobs menu item is selected.

Adobe Illustrator Plug-in - Print Item panel

Articles are Print Items

If the menu item Article has been selected in the Central Area, all Articles are displayed as Print Items. By selecting an Article all information and metadata is displayed.

Information

The Information area contains various details for the selected Print Item/Article, depending on the menu item selected. The following menu items [15] are available:

  • Print data: Here you will find various print production relevant information.
    • Document size and number of pages
    • The stored Output Configuration
    • All embedded Process Colors, Spot Colors and Technical Colors
    • Additional information for variable Jobs
    • Print Item color Separations
  • Before/After: In the future this will show the Print Item as a side by side version of the original data and the Print Item with Fixups applied for example.
  • Additional Information: In the future, additional information, i.e. attached documents for the selected Print Item will be available.
  • Ink Consumption: In the future this will show the current Ink Consumption for the selected Print Item.

All information is displayed in the Information area [16].

The footer [17] area contains important functions for editing the Print Item. These include:

  • Logging off: At the left edge of the footer, you can log out of the Workflow by clicking the icon.  
  • Check In: After editing your Print Item, you can upload the new version to the Workflow by clicking the icon. This process creates a completely new version of this Print Item in the Workflow.
  • Check Out: The right edge of the footer contains an icon with which you can open and edit the selected Print Item from the Workflow in Adobe Illustrator.

Figure 7: The Information area with the Print Data menu item selected.

Adobe Illustrator Plug-in - Print Data Stats

3.2. Geometry Boxes

The Geometry Boxes panel can be opened by selecting Window > Durst Workflow > Geometry Boxes in Adobe Illustrator. This panel allows you to set the BleedBox and/or TrimBox for the selected Print Item in Adobe Illustrator. You will find the following elements in this panel:

Tool – Two tools in the form of buttons are available:

  • Set BleedBox [18] – This tool is always available. By clicking this button, the value set under Bleed [20] is used to create or adjust the BleedBox for the Print Item.
  • Set Trim- + BleedBox [19] – This tool is only available if you have selected an object in Adobe Illustrator with either the Selection or Direct Selection tool. By selecting this button, the size of the Artboard in Adobe Illustrator is set to the size of the selected object and the Bleed for the document is set to the values set under the Bleed settings.

Bleed [20] – The BleedBox size can be entered here. However, simply entering a Bleed here does not apply it. To apply the Bleed, you must select either of the two buttons above these settings.

Current Dimensions – An overview of the current dimensions of the BleedBox and TrimBox are displayed.

Figure 8: The Geometry Boxes panel displaying the current BleedBox and TrimBox dimensions.

Adobe Illustrator Plug-in - Geometry Boxes

Set TrimBox and Bleed

You can define the TrimBox and Bleed for Print Items in Illustrator, find out how in this article: Setting the Bleed and TrimBox

3.3. White and Varnish

Open the White and Varnish panel by selecting Window > Durst Workflow > White and Varnish in Adobe Illustrator. This panel can be used to create White or Varnish as a Spot Color for selected objects. You will find the following items in this panel:

Tools – Two tools and information about how this panel functions are available in the form of buttons:

  • White [21] – This tool is only available when one or more objects are selected using the Selection or Direct Selection tool. By clicking on the White icon, the available options are displayed for creating a White object. This White object is only created by clicking the Add White button [28].
  • Varnish [22] – This tool is only available when one or more objects have been selected using the Selection or Direct Selection tool. By clicking on the Varnish icon, the available options are displayed for creating a Varnished object. The Varnish object is only created by clicking the Add Varnish button [28].
  • Info [32] – By clicking on the Info icon, the procedure for creating a White or Varnish object is described in written form (see figure 9 on the right).

Options – Depending on the tool selected, the following parameters are available to create either a White or Varnish object:

  • Origin [23] – Here you can select the type of object from the drop-down menu. Three entries are available:
    • Object(s) – Creates a White or Varnish object for the object(s) selected in Adobe Illustrator.
    • TrimBox – Creates a White or Varnish object according to the size of the Artboard in the document currently opened.
    • BleedBox – Creates a White or Varnish object the size of the BleedBox = Artboard plus Bleed, for the document currently opened.
  • Offset [24] – Determines whether the White or Varnish object to be created should be slightly larger or smaller than the selected origin. Normally, a minus offset is specified when creating a White object so that the white area does not "flash out" under the printed area. The offset can be specified in pt units.
  • Miter [25] – Defines the shape of the corners, either Miter, Round or Beveled.
  • Tint Value [26] – Determines the opacity of the White or Varnish object to created in a percentage value.
  • Miter Limit [27] – Determines how strong the peak formation should be for very acute angles. If the acute angle is below the miter value, a flattened tip is generated. If the value is above the miter boundary, a tip is created for this corner point. A value of "4" has established itself in practice as looking acceptable.

Add White/Add Varnish/Extract – Below the options area, the following functions are available in the form of buttons:

  • Add White | Add Varnish [28] – By selecting this button, the corresponding White or Varnish object will be created. Please note that the following steps are carried out:
    1. A new layer named White & Varnish is created in the file as the top layer.
    2. A Spot Color: White (slightly blue) or Varnish (slightly red) is created in the Spot Colors panel.
    3. On a new layer, the new White or Varnish object is created according options you selected.
    4. This new object is set to Overprint Fill in the Attributes panel.
  • Extract [29] – Select this button to extract the selected object from an existing overlapping White object.
  • Delete Extracted Object [30] – By activating this checkbox, when you click the Extract button, not only the selected object is removed from the existing white object, but the selected object is also deleted.
  • Resize [31] – This command is only displayed if a White or Varnish object has already been created and selected. By clicking this button, the White/Varnish object is reduced or enlarged by the value set above. The unit you specify corresponds to the unit of measurement selected in the Offset.

Overprint Preview must be activated

When you use the White and Varnish panel, corresponding objects are created on the top layer. These White/Varnish objects will conceal the objects behind them. To make underlying objects visible again, you can activate this view by selecting  Ctrl + Alt + Shift + Y  or under View > Overprint Preview in Adobe Illustrator.

Figure 9: The available options for the White and Varnish panel on the left, on the right we see the written description How to add White and Varnish.

Add White and/or Varnish to objects

Find out more about adding White or Varnish to objects in Adobe Illustrator here: Add White and/or Varnish to objects

3.4. Spot Colors

Open the Spot Colors panel by selecting Window > Durst Workflow > Spot Colors. This panel allows you to define and apply Spot Colors in Illustrator so that Spot Colors are handled the same way in Workflow as they are in Illustrator. The following elements can be found in this panel:

A List of all Spot Colors [33] – Here we see a list of all available Spot Colors for a selected Print Item.

  • Name – Name of the Spot Color
  • T – Stands for Technical Color. A "√" sign indicates that this is a Technical Color.
  • Origin – Stands for Origin. The chosen origin determines which color values are used in the output.
  • O – Stands for Output as Separation. A "√" sign indicates that the Spot Color is not calculated via Color Management but is output via the selected Process Color from the printer.
  • to – This column shows the Process Color of the printer to which the Spot Color is output.
  • I – Stands for Inverted. A "√" sign indicates that the Spot Color is inverted for the selected Process Color.

Options: If a Spot Color is selected in the Spot Colors panel, the following options can be selected:

  • Origin [34] – Different Spot Color definitions can be stored for a Spot Color in the Workflow. The following entries are available in the drop-down menu:
    • Automatic – should be selected for Spot Colors created in Adobe Illustrator, as this will automatically match the hierarchy of the origin after uploading.
    • Print Item – Defines a color value for the Spot Color name, which should only be used for the currently selected Print item in the color calculation.
    • Customer – Defines a Customer-dependent color value for the Spot Color name. As soon as a customer is assigned to a Print Item and the Spot Color name is used, this value is automatically used in color allocation.
    • Substrate – Defines a Substrate-dependent color value for the Spot Color name. As soon as a Print item is used with the selected Substrate and the Spot Color name is used, this value is automatically used in the color calculation.
    • System – Defines a System-wide color value for the Spot Color name. As soon as the Spot Color name is used in a Print Item, this value is automatically used in the color calculation.
    • Library – the color value for the Spot Color name based on a color library loaded in the Workflow. As soon as the Spot Color name is used in a Print Item and a matching entry is used in the library, this value is automatically used in the color calculation.
    • PDF – The so-called "alternative color value" for the Spot Color name, which is available for each Spot Color. The alternative color value can be defined as: Lab, CMYK or RGB. If there is no other definitions such as: Print Item, Customer, Substrate, System or Library - this value is automatically used in the color calculation.
  • Technical Colors [35] – Checkbox to define the selected Spot Color as a Technical Color or to define a Technical Color again as normal Spot Color. If this checkbox is activated, the following entries can be selected in the drop-down menu:
    • Braille – If a Spot Color is used to mark the Braille areas on a package, this entry should be selected.
    • Creasing – Select this entry if the selected Spot Color is used for Creasing Contours.
    • Cut Contour – Select this entry if the selected Spot Color is to be used for Cut Contours.
    • Imprinting – Select this entry if the selected Spot Color is to be used for an Imprint.
  • Output as Separation [36] – Checkbox to define the selected Spot Color as a Process Color of the printer or to unlink the selected Spot Color from it. If the checkbox is activated, this Spot Color is not calculated in the target color space via color management but is output as a Process Color of the printer selected next to it. A typical example of this is the color white, which is normally assigned to the process color "White".
    In the drop-down menu next to it, all Process Colors created in the Workflow are available.
  • Invert Separation [37] – Checkbox to invert the selected Spot Color in the output. This checkbox is only available for Spot Colors that have been set using the Output as Separation option. This option can be used if, you want to work with special effects or tools from ColorLogic (USA) for example.

Figure 10: The Spot Colors panel with a Spot Color selected.

Adobe Illustrator Plug-in - Spot Colors panel

Which color value is used when there are multiple Spot Color definitions for a Spot Color name?

If there are several Spot Color definitions for a Spot Color name, the color value at the top of the hierarchy - Print item | Customer | Substrate | System | Library | PDF - is applied. However, you can also set a specific origin for a Spot Color name. An origin that is defined overwrites the automatic logic.

3.5. Static Barcode

To create a Static Barcode, you must open the Static Barcode panel via Window > Durst Workflow > Static Barcode (see Figure 1). After the panel has been opened, you have various settings and options at your disposal. These options are explained as follows:

  • Options: [38] – In this area, all parameters are offered that can be used to create a Barcode or QR code. Note that certain options are only available depending on the Barcode/Code selected.
  • Source: [44] In this area the content for the selected Barcode or QR-Code can be entered as well as options such as Generating, Previewing or Resetting the Barcode.
  • Color: [49] – Options for changing the fore/background color of the Barcode are offered.
  • Info: [50] – This area shows whether the Barcode data is working correctly or if errors are occurring which prevent the generation of a Barcode as well a connection errors between the Plug-in and the Barcode service.

The Options, Source and Color areas are described in more detail below.

Options

The following parameters are available in the Options area:

  • Type [39] – Here you can select your desired Barcode or QR Code type. More than 100 different Codes are available in the drop-down menu. The tooltip of the (i) symbol next to it shows you which input values are available for the selected type. A valid sample text is also displayed below the drop-down menu.
  • Show Text [40] – By activating this checkbox, the text entered under Source is displayed below the Barcode. Note that text can only be displayed for specific Barcodes.
  • Font [41] – Select your desired font to be used in the barcode from the drop-down menu. The drop-down menu contains all fonts that are available on your operating system where Adobe Illustrator was started.
  • Font Size [42] – Enter the size of your font in pts.
  • Additional Parameters [43] – Select the Additional Parameters you need to create the Barcode or QR Code. Functions in this area may not be available for all Barcodes or QR Codes. These functions are divided into six groups; a detailed description of the options available can be found in the article: Generating Variable Data Barcodes:
    • Others – Here you can set the Bar Width Reduction for the Barcode, Notch Height for certain Barcodes, or use the background as a pattern for the Barcode or QR Code.
    • Quiet Zone – Here you can set the Quiet Zone (white border) for Barcodes and QR Codes.
    • Text Options – If the Show Text checkbox [40] is activated and a text is entered, the position of the text can be defined under these options.
    • BearersBearers are black bars with which the Barcode can be separated from the surrounding area.
    • Resolution – Barcodes may need to be optimized depending on the output resolution. Users of digital printing systems with a resolution lower than 300 dpi will probably use this option. This option can be omitted when generating Barcodes on high-resolution (< 300 dpi) printing systems.
    • Check Methods – To verify the content of a Barcode, different check methods are available. Only select a check method if a Customer explicitly requests one.

Source

In the Source area, the content to be used for the Barcode or QR Code can be entered in the text field [45] and the Code can be generated. Three buttons are available:

  • Generate [46] – By clicking on this button the Barcode or QR Code is created based on the previously set options and the entered text. The Barcode or QR Code is then generated and consists of individual vectors.
  • Show Preview [47] – By clicking on this button, the Barcode or QR Code based on the previously set options and the entered text will be generated as a preview. The difference when compared to the Generate button is that the parameters can still be edited.
  • Reset [48] – By clicking on this button all options are reset to their default values and the text entered in the text field [45] is deleted.

Color

In the Color [49] area, you can enter the color for the Barcode or QR Code and its background. Two options are available:

  • Color – Select a color value by clicking on the black color swatch for the Barcode or QR Code. This opens the color picker dialog, where you can access either the color fields created in the document or enter any color value in the offered color models by clicking on Color Models. The default color value is CMYK black (0/0/0/100).
  • Background Color – If you want to specify a background color, first activate the Background checkbox and then select your desired color by clicking on the color field. When selecting the color for the background, proceed in the same way as you did to determine the color value for the Barcode. The default color value up to version 1.7.5 is no background, starting with version 1.7.6 the background is white by default.

Figure 11: The Static Barcode panel with Code 128 shown and it's associated options.

Adobe Illustrator Plug-in - Static Barcode panel

Create a Static Barcode

To explore in more detail how Static Barcodes are created, edited and applied, you can read more in the following article: Generating Static Barcodes.

3.6. Variable Data

You can open the Variable Data panel by selecting Window > Durst Workflow > Variable Data in Adobe Illustrator. This panel allows you to create Variable Data content such as: Text, Barcodes, Images, and Shapes. The Variable Data panel is divided into three sections:

  • Job Properties [51] – In this area you can load, delete or download CSV files and define the Start at and End at values.
  • Tools [54] – This area contains all the tools available to create Variable content based on Text, Barcodes, Images and Shapes.
  • Preview [60] – this area provides live updates and feedback concerning the status of the Variable Data. The user can additionally display certain datasets by entering the dataset number.

Detailed information pertaining to the panels described above can be read below.

Job Properties

In the Job Properties area, three functions [52] are available, as well as the input options for CSV files which are used to create Variable Data:

  • Load Data Source – Use this button to upload CSV files which are used as the reference for Variable Data.
  • Delete Data Source – Use this button to remove previously uploaded CSV files.
  • Download Data Source – Use this button to download the previously loaded CSV file.

You can choose specific data sets within the CSV file by entering a Start at [53] value and an End at value. it is  important to note that, if you define a Start at and End at value these values will transfer over to the Workflow as well, for example when sending to the printer, but if these values are not entered, all records within the CSV file will be used.

Variable Data can also be created without using CSV files

Users do not necessarily have to upload a data source to create Variable Data. If you only require for example, sequential numbering (Serial Number) or an intelligent string consisting of static and variable texts, in many cases the creation of a database (in the form of a CSV file) can be omitted.

Tools

In the Tools area [54] there are four tools for creating Variable Data content as well as a delete tool. In addition, a short written description for creating Variable elements is displayed below the tools.

  • Text [55] – This option can be used to create Variable Texts based on a CSV file. Serial Numbers as well as intelligent texts consisting of static and variable content can be created and managed here as well. More detailed information describing this process is covered here: Generating Variable Data Texts.
  • Barcode [56] – This option can be used to create Variable Barcodes or QR Codes based on a CSV file. Serial Numbers as well as intelligent texts consisting of static and variable content can be created and managed here as well. A deeper description can be found here: Generating Variable Data Barcodes.
  • Image [57] – This option can be used to create Variable Images based on a CSV file. Detailed information regarding this process is covered here: Generating Variable Data Images.
  • Shapes [58] – This options provides the ability to create Variable color Shapes, based on a CSV file or a serial number. Detailed information can be found in this article: Generating Variable Shapes.
  • Delete [59] – This option can be used to delete a selected Variable Data element. Deleting does not remove the element itself, only the attributes set for that respective element are removed. For example, a rectangle remains an object in Illustrator.

Preview

In the Preview [60] area, a confirmation is shown that will either confirm that the data is being displayed correctly or if in the case of an error, an error message will be displayed. Additionally, the navigation bar [61] is available, with which individual data sets can be displayed immediately in Adobe Illustrator using the arrow symbols.

Figure 12: The Variable Data panel without an uploaded database or Tools activated.

Adobe Illustrator Plug-in - Variable Data panel

Creating Variable Data elements

For more information on creating Variable Texts, Barcodes or QR Codes, Images and Shapes the following articles are available: Generating Variable Data Texts, Generating Variable Data Barcodes, Generating Variable Data Images and Generating Variable Data Shapes.