User ManualPlug-ins Adobe IllustratorCreating, editing and deleting Production Jobs in Illustrator

Creating, editing and deleting Production Jobs in Illustrator

Adobe Illustrator > Plug-In

Availability: Durst Workflow Plus, Durst Workflow Label Plus

The Plug-in provides a seamless connection between Adobe Illustrator and the Workflow. You can easily create new Production Jobs in Adobe Illustrator and assign files from Adobe Illustrator directly to a Production Job. Learn more in this chapter:

  • How a Production Job can be created, edited, and deleted
  • Which settings are available when creating a new Production Job
  • How to add a print file to a new Production Job

1. Advance preparation

The Adobe Illustrator Plug-in allows the user to save the currently opened file as a new Production Job in the Workflow. However, empty Production Jobs can also be created and existing Production Jobs can be edited or deleted.

Before creating a new Production Job, you must connect Adobe Illustrator to the Workflow via the Plug-in and open the Production Job menu item in the File Management panel. Proceed as follows:

  1. Start Adobe Illustrator
  2. Open the File Management panel by selecting Window > Durst Workflow > File Management in Adobe Illustrator.
  3. The File Management panel displays the Log In dialog, where you must enter a Username and Password, and then click on Log In [1].

Figure 1: The File Management panel with the Log In dialog displayed.

Adobe Illustrator  - Log In window - 1.7.6
  1. After you login, a list of Production Jobs [3] is displayed by default in this panel.
  2. To add, edit or delete a Production Job, the necessary functions are available in the footer [5] of the list.

Figure 2: The File Management panel with the Production Jobs (Jobs) menu item selected.

File Management panel - 1.7.6

2. Adding, editing and deleting Production Jobs

If you have selected the Production Job menu item in the File Management panel, you can find the Production Job you are looking for as quickly as possible by entering the name of the Production Job in the Search Field [2] or by scrolling through the list of the most recently created Production Jobs. If you cannot find the Production Job in the list, it will be on the next page or the page after that. Scroll to the next, previous, first or last page by pressing the available Navigation Arrows [4].

2.1. Add a Production Job

To create a new Production Job in the Workflow in Adobe Illustrator, proceed as follows:

  1. In the File Management panel, select the Jobs menu item.
  2. Click on the + symbol [5] in the footer (see functions in Figure 2) to open the Add Production Job dialog which offers the same options as in the Workflow but is directly available in the File Management panel.
  3. In the Add Production Job dialog, settings are divided into two tabs – Production Job and Options.
  4. Enter the required information in the Production Job [6] tab. This tab is divided into three areas:
    • General [7] – Enter the Name, the Production Number and an optional Comment. If you activate Use Print Item Name for the Job Name checkbox, the name of the Production Job is automatically derived from the name of the open document in Adobe Illustrator.
    • Production Information [8] – Select the Production Date, the Production Time and Shipping Date.
    • Output Configuration [9] – Select your Printer, Print Configuration, Substrate, Substrate Definition and Color Policy.

Figure 3: The File Management panel with the Add Production Job dialog open which contains two tabs: Production Job and Options.

  1. Switch to the Options tab [10] if you want to define additional parameters for the output of Variable Data or for printing using Lead-in/out. The Options tab is divided into two sections:
    • Lead-in / Lead-out [11] – This area is only available if a roll Substrate is selected. By entering a value of 4 for Lead in and a value of 2 for Lead out, an additional four repeat lengths which only contain printed Dielines at the beginning of the print job and two repeat lengths with only printed Dielines at the end of the print job will be printed.
    • Variable Job [12] – For Variable Data, very large jobs can be split into separate jobs using the Split In option. The Start value and End value input fields can be used to limit the scope of a Variable Job.
  2. Once you have entered all the necessary information – the name of the Production Job and all parameters in the Production Job area must be filled in. You can create the Production Job by pressing Save [13].
  3. After the Production Job has been created in the Workflow, the File Management panel appears as shown below. Since we have not added file(s) to the Production Job, no Preview [14] will be displayed for the Production Job. A placeholder image is displayed instead of an Print Item preview [15].

Figure 4: The File Management panel after adding a Production Job.

File Management panel after adding a Production Job - 1.7.6

2.2. Editing a Production Job

If you want to edit Production Job settings after creating a Job, you can do so in Adobe Illustrator as well. Proceed as follows.

  1. Select the Production Job menu item from the File Management panel.
  2. Select the Production Job to be edited [16]. The search input field as well as the page numbering arrows can aid you in locating your Production Job in an expedient manner.
  3. To edit the Production Job, click on the Pencil Icon [17] in the footer to open the Edit Production Job dialog with the same options as shown in Figure 3.
  4. Perform all the editing steps and press Save again.

Figure 5: The File Management panel with a Production Job selected.

File Management - Edit or Delete a Production Job - 1.7.6

2.3. Deleting a Production Job

If you want to delete a Production Job in the Workflow, you can also do so directly in Adobe Illustrator. Proceed as follows.

  1. In the File Management panel, select Production Job.
  2. Select the Production Job to be deleted [16] (Figure 5). The search input field as well as the page numbering arrows can aid you in locating your Production Job in an expedient manner.
  3. To edit the Production Job, click on the trash can icon [18] (Figure 5) in the footer, this opens a confirmation dialog indicating that the Production Job will be permanently deleted in the Workflow.
  4. Press OK to delete the Production Job in the Workflow.

Figure 6: The File Management panel with the Delete Production Job confirmation dialog.

 

File Management - Delete Production Job dailog - 1.7.6

3. Adding a Print Item to a Production Job

After creating a Production Job and making necessary edits to your Print Item, you must add it to the Production Job by checking it in. To do this, proceed as follows:

  1. In the File Management panel, select the Production Job menu item.
  2. Select the desired Production Job [19]. The search input field as well as the page numbering arrows can aid you in locating your Production Job in an expedient manner.
  3. Selecting a Production Job selects the first Print Item in the Print Item [20] area. In our case, the previously created placeholder »Default print item«.

Figure 7: The File Manager panel with the selected Production Job, where the Print Item is selected automatically.

File Management - Default Print Item - 1.7.6
  1. To add the document currently open in Adobe Illustrator (only the document that is active can be uploaded) to the Production Job, simply click the Check In [21] icon.
  2. The check-in process starts by uploading the Print Item. A warning message indicates that the process will overwrite the current Print Item that is selected in the Print Item [20] area.
  3. Confirm the dialog by clicking Yes, which checks the Print Item into the Workflow and adds it to the Production Job.

Figure 8: A warning message appears after uploading the Print Item.

 

Warning message: overwrite the current document - 1.7.6
  1. After the check-in process is complete, the File Manager panel is reloaded and the Production Job is displayed in the following form.

Figure 9: The File Management panel after the check-in process is finished.

File Management - Checkin process complete - 1.7.6

Document name does not match the Print Item name

Note that in the current version, the Print Item name is not yet overwritten with the document name.

4. Checking the Production Job

In the last step, you can check the Production Job that you have just created which contains the Print Item in the Workflow. This also includes checking the selected Output Configuration to ensure that the correct settings for print production are configured. To be on the safe side, please check that what you entered in the Plug-in has been correctly transferred to the Workflow.

Figure 10: The Production Item that was created using the Plug-in in Adobe Illustrator as seen when opened in the Workflow.