Setting the Bleed and TrimBox

Adobe Illustrator > Plug-In

Availability: Plug-In for Adobe Illustrator Mac/Win

Problematic Print files that contain incorrect boxes or no defined TrimBox size are delivered by customers on a regular basis and can be difficult to correct. If the file contains Dielines or Marks delineating the TrimBox, a TrimBox and BleedBox can be quickly set in the Adobe Illustrator Plug-in via the Geometry Boxes panel. Learn more in this chapter about:

  • How to define a TrimBox based on an existing Dieline
  • How to adjust the BleedBox to your desired size

1. Geometry Boxes Panel Overview

You can open the Geometry Boxes panel by selecting the Window > Durst Workflow > Geometry Boxes menu in Adobe Illustrator. This panel allows you to either: set the BleedBox or enter a TrimBox size plus a BleedBox for the selected Print Item in Adobe Illustrator. You will find the following elements under this panel:

Tools – Two tools in the form of buttons are available:

  • Set BleedBox [1] – This tool is always available. By pressing this button, the values entered in the Bleed [3] input fields are used to create the Bleed for the Print Item.
  • Set Trim- + BleedBox [2] – This tool is only available if you have selected an object in Adobe Illustrator with the Selection or Direct Selection tool. By pressing the button, the size of the canvas in Adobe Illustrator is set to the size of the selected object and, additionally, a Bleed for the document is set to the value entered in the Bleed area.

Bleed [3] – Here you can define the desired size of the Bleed. However, entering the Bleed does not automatically set it. To set the Bleed, you need to use one of the two tools described above by pressing the button.

Current Dimensions [4] – This area displays the current dimensions of the open document in Adobe Illustrator.

Figure 1: The Geometry Boxes panel in the Adobe Illustrator Plug-in.

Geometry Boxes panel in the Adobe Illustrator Plug-in - 1.7.6

2. Step by Step: Set TrimBox to a selected object

We have a print file, visible below in Figure 2, from which we can draw the following conclusions:

  • The file to be printed is a label that contains the text »Water Pressure Reducing Valve« at the top. The lower area - the legend [8] (green area) – should not be printed.
  • If we examine the file either in Adobe Reader or in the preview view under the Print Data tab in the Workflow, we see that the final format (green line [5]) does not describe the area to be printed, but is set arbitrarily on the sheet.
  • The label also contains a rectangle [6], which most likely describes the Dieline. We can also see a text, »Die line does not print« [7] below the rectangle shape.

Figure 2: Below we see the customer file opened in Acrobat Pro DC.

Customer Print File example - 1.7.6

Adobe Reader or Acrobat Pro DC does not display the TrimBox Marks

Both Adobe Reader and Acrobat Pro DC can display TrimBox, BleedBox and the Page Geometry. In order to correctly see these boxes, you must activate Show art, trim and bleed boxes under Preferences > Page Display > Page Content and Information. You can find out how to do this in our Acrobat Preferences article.

In order to set the TrimBox to the rectangle [6] and to define the required Bleed, follow these three steps.

  1. The print file must be opened in Adobe Illustrator.
  2. The desired object must be selected in the file and the TrimBox with Bleed must be set to the selected object via the Geometry Boxes panel.
  3. The edited file must then be saved in the Workflow.

2.1. Step 1: Open the Print File in Adobe Illustrator

The file can be opened either locally in Adobe Illustrator or from within the Workflow. When opened locally, the file must be opened directly in Adobe Illustrator, with a connection to the Workflow established and then checked in to the Workflow afterwards. When opened from within the Workflow, the file must first be checked in to the Workflow and opened via the File Management panel in the Adobe Illustrator Plug-in and then saved in the Workflow again after editing is complete.

Opening Print Data locally in Adobe Illustrator

In order to open and edit a PDF file locally in Adobe Illustrator, the computer on which Adobe Illustrator is installed must be able to access the required resources; typically fonts – and must support the same color models used in the PDF file. If the required fonts are not available, the file cannot be edited without changing the visual appearance of the file. However, if all fonts were converted to outlines and only color constructs that are supported by Adobe Illustrator were used in the PDF file, then the PDF should be editable in Adobe Illustrator.

Unsupported Adobe Illustrator color constructs

Adobe Illustrator can display objects created with DeviceN color constructs, but individual objects produced using these constructs cannot be selected and/or edited. In order to make such color constructs editable, a Fixup called Extract Color from DeviceN is available in the Workflow.

A sample file is located at the bottom of this article, to open the file, proceed as follows:

  1. Launch Adobe Illustrator
  2. Open the file by selecting File > Open in Adobe Illustrator.
  3. If you see no warning message concerning missing fonts when opening, the file can be completely edited with the exception of possible DeviceN construct issues.

Open a file from the Workflow in Adobe Illustrator

To open the sample file from within the Workflow, proceed as follows:

  1. Start Adobe Illustrator
  2. Open the File Management panel by selecting Window > Durst Workflow > File Management in Adobe Illustrator.
  3. The File Management panel displays a Log in dialog, where you can enter the Username and Password, and then click on Log In [9].

Figure 3: The File Management panel with the Log in dialog visible.

Adobe Illustrator - Login window - 1.7.6
  1. By default, after you login, the Production Job list appears in the File Management panel.
  2. Select the menu item [11] where you uploaded the sample file in the Workflow. In our example, the file was uploaded as an Article in the Workflow, which is why we've selected Article [11] here.
  3. In order to find the file as quickly as possible, you should enter the file name in the Search Field [10] or scroll through the list of recently uploaded Articles. If you cannot find the file in the list, it will be on the next page or the page after that. Scroll to the next, previous, first or last page by pressing the available Navigation Arrows [13].

Figure 4: The File Management panel showing the first page of the Article List.

Adobe Illustrator - File Management panel - Article - 1.7.6
  1. Select the sample file from the Article [12] list. By selecting the entry, the corresponding metadata is displayed under the Print Data [14] window.
  2. To open the Article in Adobe Illustrator, click on the Check Out Selected Print Item icon [16]. The file will then be copied to the local hard drive and opened in Adobe Illustrator.
  3. If no warning message regarding missing fonts appears when opening, the file can be completely edited, except for possible DeviceN construct issues. If, however, a warning message appears, you must either install the missing fonts on your local system or apply the Fixup Convert Fonts to Outlines in the workflow.

Updating the List in the »File Management« panel

Note that when you make a change to a file in the Workflow, the change is not automatically displayed in the File Management panel. To update this list, the update icon [15] is available in the header of the File Management panel.

2.2. Step 2: Set the TrimBox to the Dieline with a 3 mm Bleed

After opening the file in Adobe Illustrator, you can simply select the existing Dieline and set the TrimBox with Bleed using the Geometry Boxes panel. Proceed as follows:

  1. Open the Set Geometry panel by selecting Window > Durst Workflow > Geometry Boxes in Adobe Illustrator. This panel is only available to users who have previously logged into the Workflow. If you have opened the sample file locally in Adobe Illustrator, you must first log in using the File Management panel.
  2. Now use the Selection tool V [18] in Adobe Illustrator to select the existing Dieline. To do this, we recommend that you switch to path view in Adobe Illustrator and isolate the corresponding object (Dieline) by clicking several times.
    • Outline View – Press Ctrl + Y to switch to Outline View. You can see whether you are using Outline View or not to the right of the document name [17].
    • Isolate Mode – To select the Dieline, you must click several times (depending on how the objects are nested) on the Dieline with the selection tool. The object nesting path [19] indicates whether you are in isolation mode or not. To exit isolation mode, click the left arrow in front of the object nesting path.

Figure 5: The sample file with the Dieline selected in Adobe Illustrator using Outline View.

Adobe Illustrator – Outline View – 1.7.6
  1. If the path [20] is isolated and selected as shown in Figure 5, you can enter the appropriate values for the Bleed [22] in the Geometry Boxes panel.
  2. The size of the TrimBox and the BleedBox can be viewed under the Current Dimensions [23] area.

Figure 6: The Geometry Boxes panel with values already entered for the Bleed.

Adobe Illustrator Plug-in - Geometry Boxes - 1.7.6
  1. After the previous actions have been completed you can click on Set Trim- + BleedBox [21], which sets the TrimBox to the selected path and creates a 3 mm Bleed.
  2. You can see the result of the process in Figure 7 below. The red line [24] marks the BleedBox and the differences in the dimensions are displayed under Current Dimensions [25].

Figure 7: The final result after setting the TrimBox and the BleedBox.

Adobe Illustrator Plug-in - Geometry Boxes - Print Item selected - 1.7.6

Use the Selection tool only!

Adobe Illustrator also includes the Direct Selection tool, which lets you quickly select individual objects. Note that objects selected with the Direct Selection tool cannot be used as a basis for setting the TrimBox.

Always use the Selection tool to select objects!

2.3. Step 3: Save your modified file in the Workflow

After you have made all the required changes, you can save the new version in the Workflow. Depending on whether you have already checked out the file from the Workflow or not, proceed as follows:

Save the file that was opened or created directly in Adobe Illustrator

Saving files that have been created or opened in Adobe Illustrator can currently only be created as a Print Item within a Production Job. Proceed as follows:

  1. Select the Production Job [26] menu in the File Management panel.
  2. First create a new Production Job by clicking on Add [27]. We provide more detailed information in the following Article: Creating, editing and deleting Production Jobs in Illustrator.

Figure 8: The File Management panel with the Production Job menu selected.

Adobe Illustrator - File Management panel - Jobs - 1.7.6
  1. After the Production Job is created, the empty Production Job is selected in the File Management panel. An empty Print Item with the name Default Print Item was also created during this process.
  2. Now you have to add the file to the Production Job. Click on Check In [28].

Figure 9: The File Management panel after creating a Production Job.

File Management panel - 1.7.6
  1. The Check in process is started. This process may take some time depending on file size and Print Item complexity. During the check-in process, you will be confronted with the following dialog.

Figure 10: An info message that the selected Print Item will be overwritten in the Production Job by the Print Item currently opened in Adobe Illustrator.

Adobe Illustrator Plug-in - Info dialog - 1.7.6
  1. After clicking on Yes [29] the selected Print item is overwritten in the Production Job with the Print Item currently displayed in Adobe Illustrator. Note that this does not change the name of the Print Item. The Print Item name must be changed in the Workflow.

Saving a file that was opened from the Workflow

Saving an edited file that was previously opened from the Workflow is very quick. To do this, proceed as follows:

  1. Simply press the Check In [30] icon in the footer of the File Management panel.
  2. The procedure for checking in the edited version starts immediately. The process progress [31] is displayed and the panel is now set to inactive.

Figure 11: The File Management panel before Checking In and During Check in of a Print Item.

File Management panel - Checking in - 1.7.6
  1. After the file has been uploaded and checked in the Workflow, the list display in the File Management panel is updated. The end result is then displayed as shown in the figure below. The Print Item now has the correct size [32] and the desired Bleed.

Figure 12: The File Management panel after checking in a Print Item.

 

Adobe Illustrator - File Management - final Print Item - 1.7.6

Checking in creates a new version of the pdf in the Workflow.

Please note that the check in process does not overwrite the existing file in the Workflow, but creates a completely new version in addition to the original version. The user can always revert to an earlier version in the Workflow by using the Revert to Version option under the Process drop-down menu.

3. Exercise file

The file below can be uploaded either directly in the Workflow or in Adobe Illustrator, so that you can follow the step-by-step guide exactly.