Fixups and Fixup Chains

In this article we'll learn:

  • How we define both Fixups and Fixup Chains in the Workflow
  • Which Fixups are available in the Workflow
  • How Fixups are created and how to upload them in the Workflow
  • How to apply Fixups to Articles or Print Items
  • How to create Fixup Chains
  • How to apply Fixup Chains

1. Fixups

Print files can be created without knowing the final output or circumstances in which the item will be printed. After checking in the print file, we can determine if specific requirements for the print item are missing, these criteria include:

  • The print file may not be correctly prepared for digital printing, e.g.: a white separation might be missing.
  • The print file has not been delivered using the correct dimensions, e.g.: various applications cannot create files larger than 5 meters in width or height.
  • Cutting information for the print file has been created in a separate file, in digital printing it is preferred to deliver both the cutfile and the print file together.
  • The print file has been created for offset printing, in digital printing, areas containing black should be created as deep black to compensate for the lack of a lighter black ink in digital printing
  • Spot Colors are converted to CMYK when the print file was created: in digital printing, color values in the output can be adjusted more precisely if they are originally defined as Spot Colors
  • The print file requires a Bleed but it is missing, typically this is handled by prepress operators.

Typical problems such as the ones mentioned above may ultimately lead to applying a Fixup or a combination of Fixups. So, what do we mean when we talk about applying a Fixup or a Fixup Chain in the workflow?

A Fixup is an instructional process that searches for certain constellations of objects and then corrects them according to predefined values. Fixup instructions are created using either the Preflight panel in Acrobat Pro or callas pdfToolbox, then loaded into the Workflow and applied to selected print items.

A Fixup Chain is a defined sequence of Fixups which are applied in a specific order. Fixup Chains are compiled, parametrized, saved and applied to selected images, print data or Articles in the Workflow based on the Fixups available.

1.1. Available Fixups

By default, the Workflow offers more than 100 Fixups for preparing and/or optimizing the print files. User-defined (custom) Fixups can be created with external tools and made available for users system-wide.

We can spare the task of uploading print files into the Workflow, and then editing them in an external application because, the Workflow provides a separate Data Preparation tab where the most common prepress Fixups can be selected and applied. The Data Preparation tab [1] is available to users of the Plus or Prepress versions of the Workflow under various menu items such as: Article, Order and Production Jobs.

Figure 1: The Data Preparation tab visible under Print Item view.

PMS WebGui :: Data Preparation

The Data Preparation tab [1] is divided into four sections:

  • Fixups or checks (red area): Select whether you want to carry out a check or a Fixup [2].
  • Filter (yellow area): Offers filter options to locate the desired Fixup as quickly as possible. Fixups can be filtered according to various criteria:
    • Text Search – If you know what you are looking for, this is the fastest way to find it.
    • Favorites – Quickly locate all Fixups that have been marked as favorites in the Workflow.
    • Category – Allows you to search for specific Fixup Categories that can, for example, correct certain types of content such as: fonts, colors, pages, etc., in the PDF file. Of course, you can also create your own Categories as needed when creating a Fixup.
    • Actions – Lets you search for Fixups that can perform specific actions such as: scaling, transforming, deleting, creating, etc.
    • Search – Lets you search for Fixups that address specific needs such as: knockouts, grommets, pantone colors, transparencies, etc.
  • Default Fixups (green area): Lists all available Fixups that are delivered with the Workflow. If a filter has been applied, only the Fixups found will be displayed in this list. If individual Fixups are used frequently by the user, individual Fixups should be marked as a Favorite by clicking on the star icon [3].
  • Custom Fixups (blue area): All Custom Fixups created and uploaded by the user are displayed in this area. After the initial installation of the Workflow this area is empty. Custom Fixups can also be marked as Favorites.

1.2. Creating and adding Fixups to the Workflow

If the default Fixups are not sufficient for your daily work, users can create their own Custom Fixups at any time. To create a Fixup we recommend that you use callas pdfToolbox.  This program can be downloaded and installed for free. In the free version, Fixups can be created and exported. Testing Fixups can only be done using a licensed version of the software. Exported kfpx files can then be uploaded to the Workflow together with the appropriate XML file. After successfully uploading the Fixup, it is available to all users of the Workflow under the Custom Fixups panel (blue area).

1.2.1. Creating a Fixup

Fixups that can be used in the Workflow use the kfpx file extension.  Fixups can either be created in Acrobat Pro Preflight or in callas pdfToolbox.

1.2.2. Exporting a Fixup from Preflight

If you want to use a check or Fixup profile from Acrobat Pro, proceed as follows

  1. Open the Preflight panel in Acrobat Pro by pressing the shortcut key (CMD)+(Shift)+(X)
  2. Select the desired profile or Fixup [4] in the list and under the Options button, select Export Profile [5].
  3. Save the kfp file to your local hard disk.

Figure 2: The Preflight panel in Acrobat Pro with a Fixup selected.

  1. Open callas pdf-Toolbox, using either the free or paid version of the software and select the menu item Profiles.
  2. This opens the Profiles dialog, where you can select the menu item Import Profile [6].
  3. Then select the kfp file previously exported from Acrobat Pro and start the import process. The import will convert the kfp file to the required extension kfpx to be processed for the Workflow.
  4. By exporting the Profile or Fixup again from callas pdfToolbox a kfpx file is now created in the correct format to be imported into the Workflow.

Figure 3: The Profile dialog in callas pdfToolbox.

1.2.3. Creating Profiles

To create a custom Fixup use either Preflight in Acrobat Pro or callas pdfToolbox. As both programs are developed by callas software, the procedure for creating checks and Fixup profiles is the same. The main difference is the range of features, as not all features from pdfToolbox are available in Acrobat Pro Preflight.

Creating Fixup profiles or entire process plans requires a thorough knowledge of PDF structures, callas pdfToolbox and at times JavaScript. Training courses are available through your local representative.

To create a Fixup proceed as follows:

  1. Start the callas pdfToolbox application and click on Tools > Profiles.
  2. Select Create Profile [7]. This will open the Create Fixup dialog.

Figure 4: The Profiles dialog in callas pdfToolbox.

  1. In the Create Fixup dialog, enter a Name [9] and a comment if needed for the Fixup and select the desired Type of Fixup [10] from the list.
  2. Select the desired options [11] that are available for the selected Fixup Type. Variables can also be entered by clicking the orange arrow [12].
  3. Complete the process by clicking OK. This will save the new Fixup within callas pdfToolbox. This Fixup can now be used to create a Profile or be applied in a Process Plan and can also be exported.

Figure 5: The Create Fixup dialog in callas pdfToolbox.

callas pdfToolbox: Create Fixup
  1. Select the previously created Fixup in the Fixup list and click on Export Profile [8] (Figure 4).
  2. The kfpx file is now saved. The Fixup is now ready to be uploaded into the Workflow.

1.2.4. Create the XML file for the Fixup

In order for the Workflow to correctly display information including variables, a description file in the form of an XML must be created for the kfpx file. Depending on the complexity of the Fixup with or without variables, XML files can be fairly complex.

To create a descriptive XML file, proceed as follows:

  1. Open a text editor – Sublime Text or Visual Studio Code for example.
  2. Fill the following tags with the appropriate descriptive content.
    • Header [13] – The header should not be changed.
    • Information [14] – Should be adapted according to your needs.
    • Variable Analyze Mode [15] – This information should not be changed.
    • Name [16] – Enter the name of the Fixup that should be displayed in the Workflow. Do not delete the language version "en_US", as it will be used as a fallback for the Workflow. This way you can just enter the name for this language and ignore the second entry of your language.
    • Description [17] – This area can be used to write a detailed explanation of what the Fixup does. If you need multiple language versions of the Fixup, this can also be added here.
    • Variables [18] – If variables have been added in your Fixup, e.g. selection lists for certain values, the variable descriptions including all options must be entered in this node. If no variables are used, remove this node.
  3. Finally, enter information that that will help the user find or filter the Fixup. Enter this information under the Category [19] lines.
  4. Save the XML file under the same name as you saved the kfpx file before. Now you have created the second required file. At this point the Fixup can be uploaded into the Workflow.

Figure 6: The XML structure for the Fixup, which was described in Figure 5.

1.2.5. Uploading Fixups in the Workflow

After you have exported a kfpx file from callas pdfToolbox and created the corresponding XML file, you can now upload these files into the Workflow. Proceed as follows:

  1. Select the menu item Administration > Settings.
  2. Select the Preflight & Fixup tab [20] under the Correction Profiles panel click on Upload [21] in the footer.

Figure 7: The Preflight & Fixup tab.

PMS WebGui :: Preflight & Fixup
  1. The Upload pdfToolbox-Profile and XML-Translation dialog will open with two dropzones, one for the .kfpx file [22] and one for the XML file [23]. Load the respective files into the drop zones by clicking and dragging or clicking on the upload zone and use file management to locate your files.
  2. Then enter an internal Key [24] which is used to call the Fixup via a REST call from an ERP system. The Fixup is named based on the title of the Fixup in the xml file.
  3. Complete the process by clicking on OK.

Figure 8: The Upload pdfToolbox-Profile and XML-Translation dialog.

PMS WebGui :: Preflight & Fixup

1.3. Applying the Fixup

People working in the prepress department often have to resort to Fixups in special situations and apply them to customers print files. A Fixup can be applied to individual Articles/Print Items or to multiple Articles/Print Items. You can choose where to apply a Fixup in different areas of the Workflow such as: the Data Preparation tab or by selecting a Fixup in Print Data view.

1.3.1. Selecting a Fixup

You can select the Fixup in two different places.

Select a Fixup using the »Data Preparation« tab

To apply a Fixup in the Data Preparation tab, perform the following steps:

  1. Select the Data Preparation tab in a Article, Order or Production Job.
  2. Locate your desired Fixup by filtering Fixups using: Categories, Actions [25] or Text criteria.
  3. The results will be displayed in the Fixups panel [26] or Custom Fixups [27].

Figure 9: The Data Preparation tab for an Article.

Selecting a Fixup in the »Print Data« tab

While the user can access all available Fixups under the Data Preparation tab, a specific set of Fixups (Fixups that are most frequently used in prepress), are available under the Print Data tab [28]. These Fixups are grouped thematically. Fixups that are relavant for the Document Information area can be selected in the footer [29].

If you find yourself selecting the same Fixups over and over, you can mark a Fixup as a favorite. In the footer of the Document Information and User-defined Fields area you will find a drop-down list of all your favorited Fixups [30].

Figure 10: The Print Data tab for an Article.

PMS WebGui :: Print Data

1.3.2. Applying Fixups

To locate and select a Fixup, use one of the two options mentioned above. To apply a Fixup, proceed as follows:

  1. Select the desired Fixup [31] either under the Data Preparation tab or the Print Data tab. In our example, our previously created and uploaded Fixup Remove existing objects outside the TrimBox is selected.
  2. In order to apply the Fixup to the selected print item in the Print Data tab, you'll need to click the Apply button. In Print Data view it is sufficient to select the Fixup in the drop-down menu and release the mouse button.
  3. This will open the Remove existing objects outside TrimBox dialog, where you cannot make any further changes in the dialog. The Name [32] and the description [33] of the Fixup are taken from the XML file and are displayed in the dialog.  The majority of Fixups in the Workflow allow or require that the user enter specific settings or variables to complete the Fixup rules.
  4. Press Apply to Selection [34] which will apply the Fixup to the selected Print Item(s).

Figure 11: The Remove existing objects outside TrimBox dialog.

PMS WebGui :: Print Data

Creating a new version of the Print Item

Please note that applying a Fixup creates a new version of the Print Item in the Workflow, which in turn is checked for errors and warnings using the check-in profile. If Fixup results do not meet your expectations, you can always revert the Print Item to a previous version.

1.3.3. Applying a fixup to selected Print Items

It is not uncommon for customers to deliver multiple iterations of a single Print file, i.e., a red, green and blue version, all of which have the same file structure. Therefore, it can be very pratical to apply the same Fixup to several files at once.

In the Workflow, Fixups can be applied to the currently selected Print Item as well as multiple Print Items. Depending on which menu item you have selected, you will need to proceed in different ways:

Selecting multiple Print Items under the »Print Data« tab

The Print Item tab [35] of an Order or Production Job can contain one or more Print Items. In order to select multiple Print Items you must either select the items by activating the checkbox [36] or select all items by clicking on the Select All or Deselect All icons [38]. The amount of Print Items contained in the Production Job and the amount of Print Items that are currently selected is displayed next to each other [37].

If you select and apply a Fixup, all Print Items will be processed in parallel and checked in again as new versions.

Figure 12: The Print Item tab of a Production Job with several Print Items.

PMS WebGui :: Print Data

Applying a Fixup to multiple »Articles«

In the case of Articles, only one Article can be displayed at a time in the Print Data tab. For companies that manage their print data based on Articles, we offer the possibility to apply a Fixup to multiple Articles as well. Proceed as follows:

  1. Select either the menu item Article > Articles or Article > Collections. This will display either the Article List or the Collection List.
  2. Locate the desired Articles in the list or the Collection.
  3. Select the Articles [39] in the list or Collection and under the Process drop-down select Apply Fixup [40] in action bar.

Figure 13: The Article List view.

PMS WebGui :: Articles
  1. After clicking on Apply Fixup the Apply Fixup to selected Article(s) dialog is displayed.
  2. Find your desired Fixup.
  3. Select the Fixup [41] and then press Apply [42], which will open the Remove existing objects outside TrimBox Fixup (see Figure 11).
  4. Confirm the dialog by pressing Apply to Selection button. The Fixup will then be applied to all selected Print Items.

Figure 14: The Apply Fixup to selected Article(s) dialog.

PMS WebGui :: Articles

2. Fixup Chains

In many cases, several Fixups need to be applied to individual Print Items or Articles. Depending on the situation and desired end product, different sizes of edge reinforcement, cutting, creasing, and folding lines and grommets need to be added. It is often necessary and advantageous to apply several Fixups in a specific sequence to selected Print Items.

Using Fixup Chains you can compile recurring processing sequences and then apply them to selected Print Items. They can even be applied when uploading Print Items into the Workflow via Hotfolders or using Force Print for example.

2.1. Creating a Fixup Chain

To create a Fixup Chain, carry out the following steps:

  1. Select the menu item Administration > Fixup Chains.
  2. Here you will find two separate panels:
    • Fixup Chains [43] – This panel shows a list of all Fixup Chains that have been created. You can search for Fixup Chains by using the normal search criteria and filters.
    • Added Fixups [45] – This panel shows the Fixups that have been added to the selected Fixup Chain, in the order that they were added or arranged.
  3. To create a new Fixup Chain, click on + New [44] in the footer of the Fixup Chains panel.

Figure 15: The Fixup Chains menu item available under Administration.

PMS WebGui :: Fixup Chains
  1. The Add Fixup Chain dialog opens, where you should enter a Name and a Comment if needed. The Key [47] is automatically created based on the name entered, but it can be changed. Please note that the key must be unique.
  2. To save the Fixup Chain, click on Save.

Figure 16: The Add Fixup Chain dialog.

PMS WebGui :: Fixup Chains
  1. After you have added a Fixup Chain, you need to add individual Fixups to the Fixup Chain in the intended order. To do this, click on Edit [46] in the footer of the Added Fixups [45] panel (both in Figure 15). The Configure Fixup Chain dialog will open.
  2. Select the desired Fixup in the Fixups [48] panel and add it to the Added Fixups [50] list by clicking on + Add Fixup [49].
  3. Add additional Fixups as needed in the same way until you are satisfied.
  4. Then select each Fixup in the Added Fixups panel and then enter the desired parameters for each Fixup in the settings area [52] next to it.
  5. If you want to change the order of the Fixups, simply drag the Fixup to the desired position by clicking on the hamburger symbol [51].
  6. To save the Fixup Chain, click on Save in the footer of the dialog.  

Figure 17: The Configure Fixup Chain dialog.

PMS WebGui :: Fixup Chains

Create Fixup Chains for individual Fixups

When opening a Fixup, certain default values, which can be set in the descriptive XML file, are already displayed in the dialog. If you want to use the same Fixup for different occasions with different default values, you can do this very easily by creating individual Fixup Chains which contain only one Fixup.

2.2. Applying a Fixup Chain

Fixup Chains can be applied to Print Items or Articles at various points in the Workflow. Fixup Chains cans also be applied when uploading print data directly into the Workflow.

2.2.1. Applying a Fixup Chain to Print Items or Articles

Fixup Chains can be applied to individual Print Items/Articles as well as to multiple Print Items/Articles at once.

To apply a Fixup Chain in Print Data view, proceed as follows:

  1. Switch to Print Data view in an Article, Order or Production Job by selecting the Print Data tab [53].
  2. In the footer of the Document Information and User-defined Fields panel you will find the Fixup Chains icon [54]. Click on it to open the Apply Fixup Chain dialog.

Figure 18: The Print Data tab of an Article.

PMS WebGui :: Print Data
  1. In the Apply Fixup Chain dialog you can select your desired Fixup Chain in the drop-down [55]. For the sake of clarity, all Fixups that will be applied are displayed in list form.
  2. To apply the Fixup Chain, click Apply to Selection [56].  

Figure 19: The Apply a Fixup Chain dialog.

PMS WebGui :: Print Data

Apply a Fixup Chain to selected Articles

If a Fixup Chain should be applied to several Print Items/Articles, proceed as follows:

  1. Select either the menu item Article > Articles or Article > Collections. This will display the Article List or the Collection List.
  2. Locate your desired Articles in the list or the Collection to be edited.
  3. Select the Articles or a Collection [57] and click on Apply Fixup Chain [58] in the action bar.
  4. This will open the Apply a Fixup Chain dialog (Figure 19). Select your desired Fixup Chain and click on Apply to Selection [56].

Figure 20: The Collections List view.

PMS WebGui :: Article Collections

2.2.2. Apply a Fixup Chain when uploading print files

If for example a customer's print data is always delivered in the same quality or if print data for certain products are always created in the same stage of development by an upstream Web2Print portal, this print data can be automatically processed using Fixup Chains when uploaded into the Workflow. Fixup Chains can be applied in two different ways when directly uploading print files in the Workflow: Hotfolders and Force Print.

Hotfolders

A Fixup Chain [60] can be selected under the Process Parameters tab [59] in the Hotfolder Setup dialog.

Figure 21: The Hotfolder Setup dialog with the Process Parameter tab selected.

PMS WebGui :: Hotfolder

Force Print

A Fixup Chain [62] can be selected in the Data Preparation panel [61] under Automation > Force Print.

Figure 22: The Force Print interface with a Fixup Chain selected.

PMS WebGui :: Force Print Job